Opened 22 months ago

Last modified 19 months ago

#3533 new bug

Deluge 2.1 does not work behind NAT

Reported by: arvidjaar Owned by:
Priority: minor Milestone: needs verified
Component: Unknown Version: 2.1.0
Keywords: Cc:


I am on Ubunutu 22.04 behind IPv4 NAT and with direct IPv6 connectivity. I am also using PPA jammy main

Recently deluge was updated to 2.1.0-0~202206282059~ubuntu22.04.1. When I added torrent via magnet link, nothing happened. No download ever started. There were no DHT nodes, so no trackers as well. I deleted torrent and added it again by downloading file. Now tracker announcement worked, but still no download. I downgraded to 2.0.3 from Ubuntu and download started immediately.

Now, there is still no DHT nodes even woth 2.0.3 so it is possible that something else has changed with my provider. But it does not explain why download did not work with normal torrent.

Deluge has been working with this provider for years in all previous versions I used (I started with 1.x, do not remember exactly).

I am happy to collect whatever diagnostic is needed if you explain how.

Change History (1)

comment:1 Changed 19 months ago by Zhoardkell

It looks like something changed in libtorrent you have to assign the listen_interface for ipv6. This does not seem to be possible in deluge but you can do it in ltConfig.

listen_interfaces,[::]:6881 - binds to all interfaces on port 6881.

Last edited 19 months ago by Zhoardkell (previous) (diff)
Note: See TracTickets for help on using tickets.