Opened 14 months ago

Closed 12 months ago

Last modified 12 months ago

#3581 closed bug (Fixed)

AttributeError: module 'libtorrent' has no attribute 'add_torrent_params_flags_t'

Reported by: twdkeule Owned by:
Priority: major Milestone: 2.1.2
Component: Core Version: 2.1.0
Keywords: Cc: twdkeule

Description

~> /usr/bin/deluged -L debug
Traceback (most recent call last):
  File "/usr/bin/deluged", line 33, in <module>
    sys.exit(load_entry_point('deluge==2.1.1', 'gui_scripts', 'deluged')())
  File "/usr/lib/python3/dist-packages/deluge/core/daemon_entry.py", line 87, in start_daemon
    from deluge.core.daemon import is_daemon_running
  File "/usr/lib/python3/dist-packages/deluge/core/daemon.py", line 19, in <module>
    from deluge.core.core import Core
  File "/usr/lib/python3/dist-packages/deluge/core/core.py", line 41, in <module>
    from deluge.core.torrentmanager import TorrentManager
  File "/usr/lib/python3/dist-packages/deluge/core/torrentmanager.py", line 53, in <module>
    lt.add_torrent_params_flags_t.flag_paused
AttributeError: module 'libtorrent' has no attribute 'add_torrent_params_flags_t'

Installed versions:

deluge-common/jammy,now 2.1.1-0~202207101304~ubuntu22.04.1 all [installed,automatic]
  Deluge Common Files

deluge-web/jammy,now 2.1.1-0~202207101304~ubuntu22.04.1 all [installed]
  Deluge Web UI

deluged/jammy,now 2.1.1-0~202207101304~ubuntu22.04.1 all [installed]
  Deluge Daemon (deluged)

libtorrent-rasterbar2.0/jammy,now 2.0.8.git20221114.64817e0e87-1ppa1~22.04 amd64 [installed,automatic]
  C++ bittorrent library by Rasterbar Software

python3-libtorrent/jammy,now 2.0.8.git20221114.64817e0e87-1ppa1~22.04 amd64 [installed,automatic]
  Python bindings for libtorrent-rasterbar (Python 3)

Change History (4)

comment:1 Changed 14 months ago by twdkeule

  • Cc twdkeule added
  • Component changed from Unknown to Core
  • Priority changed from minor to major
  • Version changed from 2.0.5 to 2.1.0

comment:3 Changed 12 months ago by Cas

  • Resolution set to Fixed
  • Status changed from new to closed

There might be more errors trying to run with libtorrent with no deprecations but this one is resolved.

comment:4 Changed 12 months ago by Cas

  • Milestone changed from needs verified to 2.1.2
Note: See TracTickets for help on using tickets.