Opened 13 years ago

Closed 11 years ago

#388 closed plugin-request (Fixed)

Add an option to inhibit the computer auto-suspending

Reported by: florian@… Owned by: andar
Priority: major Milestone:
Component: Plugin Version: 1.1.0_dev
Keywords: Cc:

Description

A lot of computers (especially laptop) are configured to sleep or hibernate after some time. This doesn't allow to let deluge download for a long time. An option should be added to enable the inhibition of auto-suspending when Deluge is running.

Stop auto-suspending with Gnome : http://live.gnome.org/GnomePowerManager/FAQ#head-1cf52551bcec3107d7bae8c332fd292ec2261760

Attachments (1)

PreventSuspend-0.1-py2.6.egg (3.4 KB) - added by d.cherniachenko@… 12 years ago.
repackage of Andreas Dalsgaard plugin - does not work in Deluge 1.1.6 (cannot enable) - can anybody fix it?

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by anonymous

  • Component changed from 0.5.x to plugin
  • Owner changed from markybob to andar
  • Priority changed from major to minor
  • Type changed from feature-request to plugin-request
  • Version changed from 0.5.8.9 to 1.1.0_dev

comment:2 Changed 12 years ago by mvoncken

  • Milestone set to 1.1.0

comment:3 Changed 12 years ago by anonymous

  • Priority changed from minor to major

comment:4 Changed 12 years ago by anonymous

  • Milestone 1.1.0 deleted

Milestone 1.1.0 deleted

Changed 12 years ago by d.cherniachenko@…

repackage of Andreas Dalsgaard plugin - does not work in Deluge 1.1.6 (cannot enable) - can anybody fix it?

comment:5 Changed 12 years ago by d.cherniachenko@…

I've tried to repackage Andreas Dalsgaard plugin (http://forum.deluge-torrent.org/viewtopic.php?f=8&t=80) into .egg format (see attachment)

But obviously my Python/Linux? experience is not enough. And even though plugin is successfully (?) installed, Deluge (1.1.6) does not want to enable it.

Can anybody have a look and fix it?

comment:6 Changed 12 years ago by ianmartin

Updated plugin available at http://github.com/yanboss/Deluge-PreventSuspend-plugin/downloads

Works for me (tm) with deluge 1.1.6 on Ubuntu 9.04

comment:7 Changed 11 years ago by Cas

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.