Opened 12 years ago

Closed 12 years ago

#448 closed bug (Fixed)

Deluge 1.0 is slow and causes networking problems for other programs

Reported by: tom@… Owned by: andar
Priority: major Milestone:
Component: Core Version: 0.9.06 (1.0.0_RC6)
Keywords: network, speed, connection Cc:

Description

I've tried the 1.0 RC5 and RC7 releases on Ubuntu Hardy and both result in the same problem:

1) upload and download speeds of deluge are extremely slow. Download stays below 100 kb/s while it was well above 1000 kb/s with the 0.5.x series. Downloading multiple torrents at the same time also seems to reduce the average download speed compared to only having one active torrent (all though I can't prove that).

2) when deluge is active it also seems to cause networking issues for the rest of the applications. Pidgin (all protocols) and Skype regularly disconnect, evolution times out connecting to mail servers and browsing using Firefox is almost impossible. Firefox takes forever to connect to a site, times out, or when it does load a page it takes a long time and then suddenly the entire page appears (in stead of rendering whatever is already received).

I've added a screenshot of the Gnome System Monitor. Even though the interface is in Dutch, you'll probably find the bottom graph (showing networking activity) interesting. This was taken just after logging in, with no real other networking activity going on other than Deluge downloading and seeding. Average downloading was probably about 75 kb/s at that time. Please let me know if you need any additional information.

Thank you for the (other than this issue) great software by the way!

Tom

Attachments (1)

Schermafdruk-Systeemmonitor.png (81.2 KB) - added by tom@… 12 years ago.
Gnome System Monitor screenshot showing remarkable network traffic

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by tom@…

Gnome System Monitor screenshot showing remarkable network traffic

comment:1 Changed 12 years ago by tribaal@…

This is probably a duplicate of the bug I entered - Exact same symptoms.

I tried to narrow it down using different settings, but found nothing conclusive so far - I'll try to run Deluge through a profiler this weekend.

  • Trib'

comment:2 Changed 12 years ago by tom@…

Just upgraded to RC8, problem remains. To give an indication, I'm currently downloading four files:

  • seeders: 103 (3302), peers: 95 (5426), availability: 126, download speed: ~10 KiB/s, upload speed: 0 KiB/s
  • seeders: 136 (10951), peers: 108 (16238), availability: 153, download speed: ~15 KiB/s, upload speed: 0 KiB/s
  • seeders: 173 (4733), peers: 97 (4372), availability: 192, download speed: ~24 KiB/s, upload speed: 0 KiB/s
  • seeders: 129 (1098), peers: 85 (1666), availability: 149, download speed: ~19 KiB/s, upload speed: 0 KiB/s

Total download speed seems to remain between 80 and 90 KiB/s. The 0 upload speed is remarkable as well. I checked the settings and have not blocked uploads. Everything on the Bandwidth tab is set to -1 and the three 'active torrents' fields on the queue tab are set to -1 as well.

comment:3 Changed 12 years ago by tom@…

corrected layout of previous message

Just upgraded to RC8, problem remains. To give an indication, I'm currently downloading four files:

  • seeders: 103 (3302), peers: 95 (5426), availability: 126, download speed: ~10 KiB/s, upload speed: 0 KiB/s
  • seeders: 136 (10951), peers: 108 (16238), availability: 153, download speed: ~15 KiB/s, upload speed: 0 KiB/s
  • seeders: 173 (4733), peers: 97 (4372), availability: 192, download speed: ~24 KiB/s, upload speed: 0 KiB/s
  • seeders: 129 (1098), peers: 85 (1666), availability: 149, download speed: ~19 KiB/s, upload speed: 0 KiB/s


Total download speed seems to remain between 80 and 90 KiB/s. The 0 upload speed is remarkable as well. I checked the settings and have not blocked uploads. Everything on the Bandwidth tab is set to -1 and the three 'active torrents' fields on the queue tab are set to -1 as well.

comment:4 Changed 12 years ago by andar

You are connected to a lot of peers which some routers may have troubles with. Judging by what you pasted you are connected to over 900 peers. Try limiting the number connections to something reasonable like 300. You may also want to try limiting the number of upload slots to something like 4. Deluge will open up more upload slots if needed.

comment:5 Changed 12 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.