Opened 16 years ago

Closed 16 years ago

#466 closed bug (WontFix)

OSX Installation Problem

Reported by: anonymous Owned by: andar
Priority: major Milestone:
Component: Unknown Version: 0.5.9.1
Keywords: Cc:

Description

http://www.unix.com/unix-dummies-questions-answers/64816-problems-installing-program-through-terminal-mac-os-x.html

Problem is documented here.

Here's where it went bad for me:

building 'deluge_core' extension /usr/bin/gcc-4.0 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/opt/local/include -I/opt/local/include/boost -I./libtorrent -I./libtorrent/include -I./libtorrent/include/libtorrent -I/usr/include/python2.5 -I/opt/local/Library/Frameworks/Python.framework/Versions/2.5/include/python2.5 -c libtorrent/src/alert.cpp -o build/temp.macosx-10.3-i386-2.5/libtorrent/src/alert.o -Wno-missing-braces -DHAVE_INCLUDE_LIBTORRENT_ASIOASIO_HPP=1 -DHAVE_INCLUDE_LIBTORRENT_ASIO_SSL_STREAM_HPP=1 -DHAVE_INCLUDE_LIBTORRENT_ASIO_IP_TCP_HPP=1 -DHAVE_PTHREAD=1 -DTORRENT_USE_OPENSSL=1 -DHAVE_SSL=1 -DNDEBUG=1 -O2 cc1plus: warning: command line option "-Wstrict-prototypes" is valid for C/ObjC but not for C++ ./libtorrent/include/libtorrent/time.hpp:157: error: 'time_traits' is not a template ./libtorrent/include/libtorrent/time.hpp:158: error: explicit specialization of non-template 'asio::time_traits' error: command '/usr/bin/gcc-4.0' failed with exit status 1

All the best

Change History (3)

comment:1 follow-up: Changed 16 years ago by andar

This does not look like 1.0.0_RC8, but rather a 0.5.x release. Could you please try with the latest RC?

comment:2 in reply to: ↑ 1 Changed 16 years ago by anonymous

Replying to andar:

This does not look like 1.0.0_RC8, but rather a 0.5.x release. Could you please try with the latest RC?

You are correct, unfortunately the issue is that 0.5.9.1 is specified in the macports stuff right now - if I can hack up the Portfile enough to get it to work I'll post it here

comment:3 Changed 16 years ago by andar

  • Resolution set to wontfix
  • Status changed from new to closed
  • Version changed from 0.9.08 (1.0.0_RC8) to 0.5.9.1
Note: See TracTickets for help on using tickets.