Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#471 closed bug (WorksForMe)

Deluge exits GUI when selecting torrent in the list

Reported by: fist_of_heaven@… Owned by: andar
Priority: major Milestone:
Component: Unknown Version: other (please specify)
Keywords: Cc:

Description

Deluge crashes, or at least exits the GUI when selecting a specific torrent in the list. It's probably related to this specific torrent, since marking other torrents works just fine. But there need to be some error control I think.

I'm running Ubuntu 8.04 and installed Deluge 1.0.0_RC8 from the .deb-package from Deluge website. I had 5 running torrents, and added this 6th (faulty somehow?) torrent to the list. I was about to pause it and therefor selecting it in the list. Each time I do this, Deluge GUI vanishes/crashes. The deamon (deluged) is still running according to the System Monitor.

At first I thought that my settings from a previous RC was somehow causing this, so I deleted the deluge settings folder and tried again with only this specific torrent. Same problem. Starting Deluge in a terminal results in this when selecting the torrent:

[DEBUG   ] 14:18:31 torrentview:450 on_button_press_event
[DEBUG   ] 14:18:31 torrentview:471 on_selection_changed
The program 'deluge' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 13819 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

The error only occurs if the torrent is in a running or seeding state. I've tried removing it by deleting the content of the torrentstates folder, and then re-adding it in a paused state. Perhaps this means there's some problem with the tracker information? As soon as I start the torrent, Deluge crashes again (not immediately, I can see it change to Announce sent and soon after it crashes). As long as I don't select the torrent, it appears to work just fine and downloading the files. As a matter of fact, I've downloaded the whole thing and extracted it (it's an XviD file). No errors, it appears to be fully functional.

At some point I somehow did manage to have the torrent selected and it then reported a problem with the Tracker, something about not being able to "bencoding" it, followed by a long row of hexadecimal numbers.

I'll attach the torrent-file, however it's from a torrent site requiring a user and password so I don't know how much this is of use to you.

Attachments (1)

Death.Race.DVDSCR.XviD-ALLiANCE.torrent (16.6 KB) - added by fist_of_heaven@… 12 years ago.
Death.Race.DVDSCR.XviD-ALLiANCE.torrent

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by fist_of_heaven@…

Death.Race.DVDSCR.XviD-ALLiANCE.torrent

comment:1 Changed 12 years ago by andar

  • Milestone set to 1.0.0
  • Resolution set to fixed
  • Status changed from new to closed

I think this might be how we display tracker errors. I have fixed this in svn and hopefully the problem will be resolved.

comment:2 Changed 12 years ago by fist_of_heaven@…

Just downloaded and tried 0.9.09, and the problem was gone for me :) Good job!

comment:4 Changed 12 years ago by anonymous

  • Milestone 1.0.0 deleted

Milestone 1.0.0 deleted

comment:6 Changed 12 years ago by anonymous

  • Milestone set to 1.1.3
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 0.9.08 (1.0.0_RC8) to other (please specify)

The problem as described occurs for me in Deluge 1.1.3

comment:7 Changed 12 years ago by andar

  • Resolution set to worksforme
  • Status changed from reopened to closed

Using the same torrent?

I can't reproduce.

comment:8 Changed 12 years ago by anonymous

  • Milestone 1.1.3 deleted

Milestone 1.1.3 deleted

Note: See TracTickets for help on using tickets.