Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#475 closed bug (Fixed)

1.0.5, crash on init, unicode folder name

Reported by: anonymous Owned by: andar
Priority: major Milestone:
Component: Core Version: 1.0.4
Keywords: Cc:

Description

I used to have a previous version (some older RC, IIRC), and i upgraded to RC8 (using the ubuntu intrepid .deb)

And now I can no longer run the program.

I investigated a bit: it seems that's it's the daemon that doesn't start. so I ran it with "-d", and I got this log:

[DEBUG   ] 21:47:00 torrentmanager:310 options: {'max_download_speed_per_torrent': -1.0, 'add_paused': False, 'prioritize_first_last_pieces': True, 'max_upload_speed_per_torrent': -1.0, 'auto_managed': True, 'max_connections_per_torrent': -1, 'download_location': u'/home/xavier/Vid\xe9os', 'file_priorities': [1, 1], 'compact_allocation': False, 'max_upload_slots_per_torrent': -1}
Traceback (most recent call last):
  File "/usr/bin/deluged", line 8, in <module>
    load_entry_point('deluge==0.9.08', 'console_scripts', 'deluged')()
  File "/var/lib/python-support/python2.5/deluge/main.py", line 169, in start_daemon
    Daemon(options, args)
  File "/var/lib/python-support/python2.5/deluge/core/daemon.py", line 52, in __init__
    self.core = Core(options.port).run()
  File "/var/lib/python-support/python2.5/deluge/core/core.py", line 297, in run
    component.start()
  File "/var/lib/python-support/python2.5/deluge/component.py", line 194, in start
    _ComponentRegistry.start()
  File "/var/lib/python-support/python2.5/deluge/component.py", line 114, in start
    self.start_component(component)
  File "/var/lib/python-support/python2.5/deluge/component.py", line 121, in start_component
    self.start_component(depend)
  File "/var/lib/python-support/python2.5/deluge/component.py", line 126, in start_component
    self.components[name].start()
  File "/var/lib/python-support/python2.5/deluge/core/torrentmanager.py", line 167, in start
    self.load_state()
  File "/var/lib/python-support/python2.5/deluge/core/torrentmanager.py", line 509, in load_state
    self.add(state=torrent_state, save_state=False)
  File "/var/lib/python-support/python2.5/deluge/core/torrentmanager.py", line 319, in add
    add_torrent_params["save_path"] = str(options["download_location"])
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 16: ordinal not in range(128)
[DEBUG   ] 21:47:01 core:910 new_release: 0.9.08

Change History (8)

comment:1 Changed 12 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

Fixed [3819]

comment:2 Changed 12 years ago by anonymous

I confirm! I applied the changes from [3819], and it works now.

comment:3 Changed 12 years ago by Adam Ehlers Nyholm Thomsen <adament@…>

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Summary changed from 1.0.0_RC8, crash on init, unicode folder name to 1.0.5, crash on init, unicode folder name
  • Version changed from 0.9.08 (1.0.0_RC8) to 1.0.4

The fix doesn't work when you load a str containing unicode characters, since the encode('utf-8') function assumes the string only contains ascii characters. Try running u'æøå'.encode('utf-8').encode('utf-8) the second encode fails. I get this error on 1.0.5.

comment:4 Changed 12 years ago by Adam Ehlers Nyholm Thomsen <adament@…>

I just realised I should probably mention I run python 2.6 but I just tried the double encode on python 2.3.4 and it gave the same error.

comment:5 Changed 12 years ago by andar

  • Milestone changed from 1.0.0 to 1.0.6
  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed [4220]

Thanks!

comment:6 Changed 12 years ago by anonymous

  • Milestone 1.0.6 deleted

Milestone 1.0.6 deleted

comment:7 Changed 11 years ago by alisazhao2009

links of london jewelry discount , famous for its sweetie and friendship bracelets. Christian Audigier designer, ed hardy , is a brand of Christian Audigier, and now are favored in the moderning world as a mark of its nice tatoo.

Note: See TracTickets for help on using tickets.