Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#543 closed bug (Fixed)

UPnP fails to establish port mappings in version 1.0.2

Reported by: brown Owned by: andar
Priority: major Milestone:
Component: Core Version: 1.0.5
Keywords: upnp, port forward Cc:

Description

I am using the Ubuntu 8.04 Hardy .deb of version 1.0.2 downloaded from the deluge website.

Upon upgrading from v1.0.0 to v1.0.2 UPnP no longer establishes any forwarded ports on my router.

Downgrading to v1.0.0 fixes the issue.

A wireshark log of v1.0.2 shows no UPnP communication with the router at all.

Change History (15)

comment:1 Changed 12 years ago by aghus

I confirm this.

I'm using the same version of Deluge and the same version of Ubuntu.

comment:2 Changed 12 years ago by andar

  • Milestone set to 1.0.3
  • Resolution set to fixed
  • Status changed from new to closed

Fixed [4002].

This will be in 1.0.3

comment:3 Changed 12 years ago by mickstephenson@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

1.0.3 hasn't fixed this for me, I'm on intrepid, and my router has the dd-wrt firmware installed.

comment:4 Changed 12 years ago by aghus

And again, I confirm this.

I'm using the version from the deluge website on Hardy

comment:5 Changed 12 years ago by tim.kornhammar@…

I can confirm on 1.1.0-DEV (r4087), UPnP should be prioritized.

comment:6 Changed 12 years ago by andar

  • Milestone changed from 1.0.3 to 1.0.4
  • Resolution set to fixed
  • Status changed from reopened to closed
  • Version changed from 1.0.2 to 1.0.3

This has been fixed in svn and will be in the next release.

comment:7 Changed 12 years ago by mickstephenson@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Still not working on 1.0.4 for me

comment:8 Changed 12 years ago by aghus

  • Priority changed from minor to major
  • Version changed from 1.0.3 to 1.0.4

I don't know what happened, but still not working.

comment:9 Changed 12 years ago by brown

fixed for me in v1.0.4

comment:10 Changed 12 years ago by mickstephenson@…

Fixed for me in 1.0.5, might be possible to mark this as closed now.

comment:11 Changed 12 years ago by anonymous

Sorry to report more trouble, but 1.0.5 still shows "no incoming connections" for me on Ubuntu 8.04. The only version that seemed to work well for me on this hardware was 1.0.0 - everything released since then fails the port test.

comment:12 Changed 12 years ago by cesarg9 at gmail dot com

same for me, upnp not working using version 1.0.5 in gentoo, not sure how i can try to debug this.

comment:13 Changed 12 years ago by cesarg9

upnp.log generated using TORRENT_UPNP_LOGGING http://pastebin.com/m32eb45f5

comment:14 Changed 12 years ago by andar

  • Milestone changed from 1.0.4 to 1.0.6
  • Resolution set to fixed
  • Status changed from reopened to closed
  • Version changed from 1.0.4 to 1.0.5

This should be fixed in 1.0.6

comment:15 Changed 12 years ago by anonymous

  • Milestone 1.0.6 deleted

Milestone 1.0.6 deleted

Note: See TracTickets for help on using tickets.