Opened 16 years ago

Closed 14 years ago

#561 closed bug

ETA becomes Infinity if priority for one or more files is set to "Not Download"

Reported by: anonymous Owned by: andar
Priority: major Milestone:
Component: GTK UI Version: 1.1.8
Keywords: Cc:

Description

ETA becomes Infinity if priority for one or more files is set to "Not Download". When switching priorities back to normal, high or highest ETA becomes correct immideatelly.

Change History (7)

comment:1 Changed 16 years ago by andar

  • Resolution set to worksforme
  • Status changed from new to closed

Unable to reproduce.

comment:2 Changed 16 years ago by Radhakrishna bhat

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 1.1.0_dev to 1.0.5

Steps to reproduce.


In a torrent where more than one file is there. Go to Files Tab, press ctrl+A. right click and click "Do not download". At the same time de-select one of it and make it High priority. The ETA becomes infinity.

ETA would again become normal when all files are selected "high priority" or so..

comment:3 Changed 15 years ago by anonymous

  • Milestone 1.1.0 deleted

Milestone 1.1.0 deleted

comment:4 Changed 15 years ago by taoufix

Same here. I have to use python interpreter as a calculator to get an ETA :(

comment:5 Changed 15 years ago by anonymous

  • Version changed from 1.0.5 to 1.1.8

comment:6 Changed 15 years ago by andar

  • Status changed from reopened to pending

I still cannot reproduce this. Is this still an issue with 1.2?

comment:7 Changed 14 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.