Opened 16 years ago

Closed 16 years ago

Last modified 15 years ago

#624 closed feature-request (Fixed)

Ubuntu priority display

Reported by: Owned by: andar
Priority: minor Milestone:
Component: Core Version: 1.0.6
Keywords: Ubuntu Priority Display Cc:


In ubuntu when changing a files priority the display does not change, ie. it remains as 'Normal Priority' with the green icon. Internally however it does seem to change as files set to 'Do Not Download' don't download.

Change History (12)

comment:1 in reply to: ↑ description Changed 16 years ago by anonymous

Upon closer inspection, the files priority does not change and everything is stuck on 'Normal' Also, I am using Ubuntu 8.10 Gnome

comment:2 Changed 16 years ago by andar

Are you using compact allocation? If so, then file priorities will not work.

comment:3 Changed 16 years ago by DreamSonic

  • Priority changed from minor to major

Same story. I specifically checked Full Allocation. No changes.

comment:4 Changed 16 years ago by anonymous

  • Component changed from gtkui to core

comment:5 Changed 16 years ago by andar

Did you actually add the torrent with full allocation? Just changing the setting in Preferences won't change anything for existing torrents in your session.

Can you provide log files of both the gtkui and the core?

comment:6 Changed 16 years ago by

I tested it with another torrent and it worked fine.

comment:7 Changed 16 years ago by

Sorry about the excessive comments, but I was using it again and it wouldn't change priorities, I checked allocations, they were on full, I removed the torrent and added it again and still no priority.

Where would I find the logs?

comment:8 Changed 16 years ago by andar

The daemon generally logs to ~/.config/deluge/deluged.log but the client does not log automatically. You can just run them from the console to get the log output: deluged -d

comment:9 Changed 16 years ago by DreamSonic

  • Priority changed from major to minor
  • Type changed from bug to feature-request

I've checked the logs, it kept saying: "setting file priority with compact allocation does not work!". So I re-added the torrent with full allocation on and it seems to work. Thanks.

But I'd rather see this warning in UI, not in logs.

comment:10 Changed 16 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

Yes, an UI alert should come up, but this 'fix' was added kind of late and I decided to add that to 1.1.

comment:11 Changed 16 years ago by andar

  • Milestone set to 1.1.0

I have fixed this in [4364]

comment:12 Changed 15 years ago by anonymous

  • Milestone 1.1.0 deleted

Milestone 1.1.0 deleted

Note: See TracTickets for help on using tickets.