Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#633 closed bug (Fixed)

Deluge freezes and all torrents disappear

Reported by: BoyHowdy Owned by: andar
Priority: major Milestone: 1.3
Component: Core Version: 1.1.7
Keywords: pBCFLTZuZnLyiXFNYsS Cc:

Description

Deluge sort of freezes and all the torrents disappear. The program remains active as clicking on the tray icon brings up the GUI but with no torrents. The program also refuses to close via normal methods when goofed.

When restarted the torrents are back but Deluge rechecks all active torrents and anything downloaded since the last normal closing is lost.

This only seems to happen when a downloading torrent attains a high download speed

Attachments (1)

deluge_logs (41.7 KB) - added by MyXiLo 13 years ago.
python -dv /usr/bin/deluge > deluge_logs 2> deluge_logs

Download all attachments as: .zip

Change History (26)

comment:1 Changed 13 years ago by anonymous

When this problem occurs deluged no longer appears in the process list in the system monitor however deluge is still listed

comment:2 Changed 13 years ago by anonymous

  • Version changed from 1.0.6 to 1.0.7

I have this same problem, but it is triggered when I try to "Move Storage" of many (around 300) torrents at once.

comment:3 Changed 13 years ago by anonymous

Have same problem, but in my case deluged eats all cpu resources and gui is not responding to any actions. After killing deluged, deluge gui becomes accessible but with no torrents and "not connected" status. This behavior is stable but it is hard to tell when it is happening because it can work normally a couple of hours. Maybe it is related to system standby state, because everytime i found deluge not working is right after system being in standby for a couple of hours.

comment:4 Changed 13 years ago by anonymous

  • Version changed from 1.0.7 to 1.1.0_RC2

Just starting using Deluge, having the same problem as those above except this is occuring randomly on me, it's not happening due to any large movements, high download speeds or computer standby. The main window shows my torrents for maybe 10 minutes or less then they disappear, the only way to fix the problem is by quitting deluge from within and restarting it.

comment:5 Changed 13 years ago by martinjester

  • Version changed from 1.1.0_RC2 to 1.1.0

I am having this problem as well.

It started when I tried to move several torrents at once, but now whenever I start deluge, it starts normally, but then I get the "Not Connected" message after ~2 minutes. Also, when I go into the preferences after it happens, all the options are grayed out.

I removed the deluge-torrent package, and the reinstalled, but this did not resolve the issue.

I moved my ~/.config/deluge folder, and this seems to have resolved the issue, though it wiped out my preferences in the process.

I moved the preferences back in, and started deleting them one at a time. It appears that the one that had to be removed to resolve the issue was core.conf, though this did cause the loss of all my settings, though not any of the torrent data.

comment:6 Changed 13 years ago by r0ckarong

I used to have this problem several times already and each time it was some faulty torrent file that did it. I just removed the torrent file and reloaded it from where I got it and then it kept working. One time the new file was corrupted as well but unfortunately I didn't keep any of them for inspection :/

Not a solution for those with big queues running but that's how I figured out these crashes a while ago.

comment:7 Changed 13 years ago by dlgtho@…

happened to me today after upgrade to 1.1.1. left it for a night and found it like described in the morning. 3 torrents that were downloaded are now gray and in constant state of checking. i can't revive them. all the rest of the torrents are alright. every release has some surprise... pff. for some reason, every release has some critical bugs

comment:8 Changed 13 years ago by anonymous

  • Version changed from 1.1.0 to 1.1.2

I have the same problem with deluge 1.1.2. Until yesterday, this version ran just fine for me. But since today, I experience the following behavior

When I start Deluge per Terminal I get the following first:

1.1.2
Unhandled exception in thread started by

Then, after 2 or 3 minutes, this happens:

terminate called after throwing an instance of 'boost::bad_lexical_cast'
  what():  bad lexical cast: source type value could not be interpreted as target
[ERROR   ] 14:38:04 client:146 Socket or XMLRPC error: (111, 'Connection refused')

comment:9 Changed 13 years ago by BoyHowdy

As of version 1.1.2 the problem no seems to happen :-)

comment:10 Changed 13 years ago by BoyHowdy

As of version 1.1.2 the problem no longer seems to happen :-)

(oops on the typo)

comment:11 Changed 13 years ago by anonymous

terminate called after throwing an instance of 'asio::system_error'

what(): Address family not supported by protocol

[ERROR ] 16:04:45 client:146 Socket or XMLRPC error: (111, 'Connection refused')

Still happened on Chinese encoding torrent

comment:12 Changed 13 years ago by anonymous

  • Milestone set to 1.1.3
  • Version changed from 1.1.2 to other (please specify)

still present in 1.1.3 (kubuntu interpid amd64)

comment:13 Changed 13 years ago by anonymous

1.1.3 still got the same problem (ubuntu 8.10 64bits)

comment:14 Changed 13 years ago by andar

Are you getting any error message? Is it segfaulting? Can you get a backtrace?

Changed 13 years ago by MyXiLo

python -dv /usr/bin/deluge > deluge_logs 2> deluge_logs

comment:15 Changed 13 years ago by MyXiLo

  • Milestone 1.1.3 deleted
  • Version changed from other (please specify) to 1.1.5

Same problem with deluge 1.1.5 on ArchLinux. Here are several logs :

$ deluge --version
1.1.5
$ deluge -L info
[INFO    ] 10:12:49 main:105 Deluge ui 1.1.5
[INFO    ] 10:12:49 main:111 Starting ui..
[INFO    ] 10:12:49 ui:52 Starting GtkUI..
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
1.1.5
[INFO    ] 10:12:52 dbusinterface:76 Registering with DBUS..
/usr/lib/python2.6/site-packages/deluge/ui/gtkui/mainwindow.py:51: GtkWarning: gtk_toolbar_set_icon_size: assertion `icon_size != GTK_ICON_SIZE_INVALID' failed
  "glade/main_window.glade"))
[INFO    ] 10:12:55 connectionmanager:478 Starting localhost:58846 daemon..
[INFO    ] 10:12:56 client:160 Setting core uri as http://localclient:0e16256457e4ea9cf386d0744d15ce8824e3f83d@127.0.0.1:58846
[ERROR   ] 10:16:47 client:146 Socket or XMLRPC error: [Errno 111] Connexion refusée
[INFO    ] 10:16:47 client:160 Setting core uri as None
[INFO    ] 10:17:20 client:160 Setting core uri as None
[INFO    ] 10:17:20 client:160 Setting core uri as None

Please tell me how to get a backtrace and I'll do it.

It seemed to have happened after I added http://torrentz.com/53bf82721b7e0ad15ab1147da8d766d0d7ed13a4

comment:16 follow-up: Changed 13 years ago by MyXiLo

  • Version changed from 1.1.5 to 1.1.6

Still in Deluge 1.1.6 on ArchLinux. Please, can someone tell me what informations (and how to get them) we need to fix that bug.

comment:17 in reply to: ↑ 16 Changed 13 years ago by MyXiLo

Replying to MyXiLo:

Still in Deluge 1.1.6 on ArchLinux. Please, can someone tell me what informations (and how to get them) we need to fix that bug.

Lines (are these lines ?) have changed since 1.1.5

$ deluge -L info
[INFO    ] 18:26:24 main:117 Deluge ui 1.1.6
[INFO    ] 18:26:25 main:123 Starting ui..
[INFO    ] 18:26:25 ui:64 Starting GtkUI..
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
1.1.6
[INFO    ] 18:26:29 dbusinterface:88 Registering with DBUS..
/usr/lib/python2.6/site-packages/deluge/ui/gtkui/mainwindow.py:63: GtkWarning: gtk_toolbar_set_icon_size: assertion `icon_size != GTK_ICON_SIZE_INVALID' failed
  "glade/main_window.glade"))
[INFO    ] 18:26:33 connectionmanager:490 Starting localhost:58846 daemon..
[INFO    ] 18:26:36 client:172 Setting core uri as http://localclient:0e16256457e4ea9cf386d0744d15ce8824e3f83d@127.0.0.1:58846
[ERROR   ] 18:29:16 client:158 Socket or XMLRPC error: [Errno 111] Connexion refusée
[INFO    ] 18:29:16 client:172 Setting core uri as None
[INFO    ] 18:31:33 client:172 Setting core uri as None
[INFO    ] 18:31:33 client:172 Setting core uri as None

comment:18 Changed 13 years ago by googlaaa

  • Keywords pBCFLTZuZnLyiXFNYsS added
  • Milestone set to 1.1.3

comment:19 Changed 13 years ago by djobbito@…

  • Resolution set to fixed
  • Status changed from new to closed

Hi everybody,

I had the same message: client:158 Socket or XMLRPC error: [Errno 111] Connection refused

With deluged not processing anymore and deluge without torrent.

It seems that if you install libxmlrpc-light-ocaml-dev & libxmlrpc-c3-dev, the problem won't happen anymore.

It seems that deluged need libxmlrpc libraries to work properly on the network.

I've tested deluge with the libraries installed, and I can confirm that the error has stopped.

I am on ubuntu jaunty.

Please somebody test this solution on another distro and give the result.

Tks

comment:20 Changed 13 years ago by m.barren@…

  • Version changed from 1.1.6 to 1.1.7

I think this problem has to do with UPnP. The router I use apparently provides a faulty UPnP interface, and once I switched off the UPnP option in deluge, everything seemed to work again.

To do that, I disconnected my network so deluge cannot communicate with my router, then ran deluge (which ran fine), ticked the option off and re-opened it. All good now.

comment:21 Changed 13 years ago by m.barren@…

... continuing from my last post, I just figured out using gupnp-universal-cp, that the router doesn't provide upnp function to set port forwarding!

comment:22 Changed 13 years ago by MyXiLo

I installed xmlrpc-c on ArchLinux?, and the problem still happens. ArchLinux? doesn't have libxmlrpc-light-ocaml-dev but Deluge doesn't use ocaml anyway.

comment:23 Changed 12 years ago by anonymous

  • Milestone 1.1.3 deleted

Milestone 1.1.3 deleted

comment:24 Changed 12 years ago by ap0

  • Milestone set to 1.3.0

The problem is still there on ArchLinux? ='(

comment:25 Changed 12 years ago by alisazhao2009

If you’re a dedicated follower of tiffany co like me. Don't miss the tiffany uk & co. on sale including pendants, necklace, earrings, bracelets on line. tiffanys is the one thing that outlasts the cake, champagne and music.

Note: See TracTickets for help on using tickets.