Opened 13 years ago

Closed 12 years ago

#639 closed bug (Fixed)

Torrent checking gets "stuck"

Reported by: jonesmz@… Owned by: andar
Priority: major Milestone:
Component: Unknown Version: other (please specify)
Keywords: Cc: Ristioja@…, mcv@…

Description

When telling deluge to for a re-check of a torrent, the torrent displayed "checking", with no % on the main torrent list, and 100% on its percentage on the statistics tab, for over 3 hours, and no other actions on that torrent would stop it aside from removing the torrent. Additionally, several other torrents were queued for a re-check, and would not bein checking until the first one was removed.

Change History (13)

comment:1 follow-up: Changed 13 years ago by civmaniac@…

  • Version changed from 1.0.6 to 1.0.7

Also, it 100% happens, when download location of some torrents is on mounted drive and drive is not mounted upon deluge start.

comment:2 in reply to: ↑ 1 Changed 13 years ago by anonymous

Replying to civmaniac@…:

Also, it 100% happens, when download location of some torrents is on mounted drive and drive is not mounted upon deluge start.

So, I'm having this problem, the only two torrents that are having issues are on a mounted drive different from that of deluge, and maybe not mounted on deluge's first start, though the problem remains if I stop/restart deluge (with other drive remaining mounted in meantime)

I'm running Gentoo, 2.6.28, Deluge-1.1.1

Any suggestions/counsel?

comment:3 Changed 13 years ago by jonesmz@…

I've seen some improvement to this in 1.1.2, though the problem isn't completely fixed.

my work around was to stop using storage on an external device.

Could we perhaps add a check to see if the media is mounted before trying to read from it? if its not notify the user via popup and wait for them to press "ok" or "ignore"?

comment:4 Changed 13 years ago by anonymous

  • Version changed from 1.0.7 to other (please specify)

I still have this issue with 1.1.3. Deluge will check 2 torrents successfully and then stops.

comment:5 Changed 13 years ago by Ristioja@…

  • Cc Ristioja@… added

Same in 1.1.8.

comment:6 Changed 13 years ago by andar

Are you running libtorrent 0.14.4?

comment:7 Changed 13 years ago by Ristioja@…

Using Gentoo Linux, libtorrent does not appear to be installed. In case deluge uses it, it must be bundled?

comment:8 Changed 13 years ago by mcv@…

  • Cc mcv@… added

I've noticed that Deluge can't do "open folder" command on such "stuck in checking" items.

So here is simple solution: before running Deluge, first open all volumes with stored torrents in file browser. In my case its Gnome's Nautilus. Next run Deluge, and it will smoothly recheck all torrents.

comment:9 Changed 12 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

This was a bug in libtorrent. Please upgrade to the latest version.

comment:10 Changed 12 years ago by jotik

  • Resolution fixed deleted
  • Status changed from closed to reopened

I have Rasterbar's libtorrent 0.14.7 (the latest at the moment) and it still doesn't work, torrents stay at 0%. What version of libtorrent did you think it was fixed in, andar?

comment:11 Changed 12 years ago by andar

There was a recent fix in the RC_0_14 branch of libtorrent that _should_ fix this issue. Unfortunately, it wasn't fixed in time for 0.14.7. Could you please try the RC_0_14 branch of libtorrent and see if that solves the issue for you?

comment:12 Changed 12 years ago by jotik

Ok, I tracked the bug down to revision 4042 of libtorrent: http://libtorrent.svn.sourceforge.net/viewvc/libtorrent?view=rev&revision=4042

After applying this change to the source things started rolling again! :) So I think this bug is pending on an upcoming libtorrent-0.14.8 release perhaps.

Thanks again! Now hundreds of torrent files can be seeded again! =]

PS: Your trac setup lacks the option to resolve this issue as "upstream".

comment:13 Changed 12 years ago by andar

  • Resolution set to fixed
  • Status changed from reopened to closed

This is fixed upstream in libtorrent and will be in 0.14.8/0.15

Note: See TracTickets for help on using tickets.