Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#686 closed bug (Fixed)

Checking fails completely

Reported by: kokolist@… Owned by: andar
Priority: major Milestone:
Component: Unknown Version: 1.2.0_dev
Keywords: libtorrent, check, checking Cc: hoverhell@…, AlexC

Description

After being killed ( I don't know what would happen if these torrents needed checking for other reasons ) deluge only checks two of the torrents waiting to be checked and then stops. If I restart it (both ui and deamon) it checks another couple and stops checking again. Otherwise it seems functional. Restarting the gtk ui doesn't work, nor does force recheck or any other idea I had.

Change History (15)

comment:1 Changed 12 years ago by HoverHell

  • Cc hoverhell@… added
  • Version changed from 1.1.0_RC2 to 1.1.0

I have the same problem (Deluge 1.1.0 for debian lenny). Any suggestions on what I can check regarding this problem?

  • When I added new torrents for the first time, it only checked approx. 10 of them, and newly added are in described state now.
  • I have a suspicion that this might be related to upgrade.

comment:2 Changed 12 years ago by HoverHell

Tried adding 136 torrents to clean config (moved away .config/deluge directory). Got 9 downloading, 1 seeding (e.g. it was completed sometime before), and 126 hanging in 'Checking' without any progress.

comment:3 Changed 12 years ago by m.frydenlund@…

  • Version changed from 1.1.0 to 1.2.0_dev

i had something simlar to this happen to me on sid and svn build

while adding 80 half finnished torrents. 5 of them got stuck in the middle of checking. though the REST finnished. downgrading to 1.1.0 fixed the problem though

comment:4 Changed 12 years ago by anonymous

Still have this problem on 1.1.1 I guess this might be different problem from m.frydenlund :) Anyway, having some little development skills and some interest in this problem, what can I possibly check to resolve this problem?

comment:5 Changed 12 years ago by AlexC

  • Keywords libtorrent check checking added
  • Priority changed from minor to critical
  • Summary changed from Checks only two torrents and then stops to Checking fails completely

Same has happened to me. Four torrents out of seventeen have stopped during checking. Don't know why they where checking. Torrent sizes: 712.4, 71.4, 69.6, 24.5 Stopped at: 1.26, 1.40, 11.31, 16.54 % Three only checked one (or part of one) file before stopping. One checked two files. Apparently is libtorrent bug.

comment:6 Changed 12 years ago by AlexC

  • Cc AlexC added

comment:7 Changed 12 years ago by HoverHell

Is there separate ticket for problem of 'halfway stopped checking' torrents? Anyway, when trying to delete such stuck torrent (I was thinking of re-adding them), deluged crashed. Log 1: http://pastebin.com/f118744f8 (annotate-output'd). Log 2: http://pastebin.com/f5fdb282 crash moment line is highlighted.

Anything I should try?

comment:8 Changed 12 years ago by anonymous

  • Resolution set to fixed
  • Status changed from new to closed

comment:9 Changed 12 years ago by HoverHell

  • Priority changed from critical to major
  • Resolution fixed deleted
  • Status changed from closed to reopened

Not sure about reason of it being set to 'closed'… with deluge 1.2.0-dev (svn 4810, libtorrent svn 3290) I don't get the problem with half-checked torrents (again), but I still get problem with only 2 torrents getting checked on every run. (will probably restart the daemon few more times in attempt to fix that, though).

  • Changing to 'major' for now because of option to restart the daemon multiple times.

comment:10 Changed 12 years ago by andar

Is the torrent going into an error state? Can you check the daemon's debug logs for file_error_alerts?

comment:11 Changed 12 years ago by HoverHell

Is the torrent going into an error state? Can you check the daemon's debug logs for file_error_alerts?

Like description suggests, it hangs in 'Checking' state. And there's no messages (even on debug level) that can be attributed to this problem (only line with 'file_error' is about registering handler for this alert) — all output at the moment it gets stuck seems to be normal (only some messages regarding changing state and tracker problems).

Log around the moment it finished checking 2nd torrent (leaving 3 more torrents not getting checked): http://pastebin.com/m5e462615

comment:12 Changed 12 years ago by rod@…

upgrade to 1.1.4 fixed this problem for me (was using 1.1.1) Thanks

comment:13 Changed 12 years ago by chris.weedman@…

I can confirm that this issue still exists with 1.1.4 & 1.1.5. (Gentoo x86_64, deluge running via remote connection setup)

However, if I check any of my torrents, it will always get stuck at "Checking 0.0%". It used to check half correctly, and stuff up on the others, but now none will check.

comment:14 Changed 12 years ago by HoverHell

I still have this problem with svn rev. 4810 build. And, still, restarting the daemon aproppriate amount of times still temporarily helps :)

comment:15 Changed 11 years ago by andar

  • Resolution set to fixed
  • Status changed from reopened to closed

This was a bug in libtorrent. Please upgrade to the latest version.

Note: See TracTickets for help on using tickets.