Opened 11 years ago

Last modified 10 years ago

#698 reopened feature-request

Show reason why connection failed to daemon

Reported by: anonymous Owned by: andar
Priority: major Milestone: Future
Component: GTK UI Version:
Keywords: Cc: aagaande@…

Description

As summary says, if I run deluged as user bittorrent, and start up deluge on my main user, it fails to connect to the daemon. It will show as localhost being offline, and hang if I try to start anyway (hang trying to start a daemon on a port already in use I suspect).

However using a seperate python program I can import deluge.ui.client and get a list of running torrents just fine.

Change History (5)

comment:1 Changed 11 years ago by aagaande@…

  • Cc aagaande@… added

comment:2 Changed 11 years ago by cmr@…

i don't think this is related to whether the daemon is running as a different user, or whether the UI is trying to spawn its own daemon. i can't seem to connect to *any* deluged that is not actually running on localhost.

for example, if i create an SSH tunnel connecting local port 48846 to remote port 58846 on a machine that has a running deluged, i can get a response over the tunnel using telnet or a web server pointed to localhost:48846, but the deluge UI will just hang up until i kill it. the same thing is true if i tunnel it to local port 58846.

so, i logged into the remote machine running deluged and opened up ports on the router and firewall for 58846... again, i can connect directly to the port, but whether i give the deluge UI my IP address or domain name, the "connect" button is actually disabled.

both systems are running deluge 1.1.0_RC3 on i386 ubuntu 8.10.

comment:3 follow-up: Changed 11 years ago by andar

  • Resolution set to invalid
  • Status changed from new to closed

This is not a bug. You are required to either give the second use access to the ~/.config/deluge/auth file or setup a username/password for them.

See: http://dev.deluge-torrent.org/wiki/Authentication

comment:4 in reply to: ↑ 3 Changed 10 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

I was having the same problem and it took me a while to figure out what was happening. I think there should be a message saying "wrong password" or something. not just hang up.

Replying to andar:

This is not a bug. You are required to either give the second use access to the ~/.config/deluge/auth file or setup a username/password for them.

See: http://dev.deluge-torrent.org/wiki/Authentication

comment:5 Changed 10 years ago by andar

  • Component changed from core to gtkui
  • Milestone set to Future
  • Summary changed from deluge fails to connect to daemon running as seperate user on localhost. to Show reason why connection failed to daemon
  • Type changed from bug to feature-request
  • Version 1.1.0_RC3 deleted
Note: See TracTickets for help on using tickets.