Opened 12 years ago

Closed 12 years ago

#715 closed bug (Fixed)

NoCoreError : 'The core proxy is invalid.'

Reported by: qxtr01@… Owned by: andar
Priority: major Milestone:
Component: Unknown Version: 1.1.0
Keywords: Cc:

Description

when trying to connect to the deluge daemon from http://localhost:8112/ i get the following error message:

--Deluge Error--
NoCoreError : 'The core proxy is invalid.'
path : /connect
file : /usr/lib/python2.5/site-packages/deluge/ui/client.py in call, line 111

--Input--
<Storage {'other_uri': '', 'uri': 'http://localhost:58846', 'submit': 'Connect'}>

--Versions--
WebUi : 1.1.0-RC3r
Python 2.5.2 (r252:60911, Oct 31 2008, 19:42:44) 
[GCC 4.1.2 (Gentoo 4.1.2 p1.1)]:

--Traceback--
  File "/usr/lib/python2.5/site-packages/deluge/ui/webui/lib/webpy022/webapi.py", line 310, in wsgifunc
    result = func()
  File "/usr/lib/python2.5/site-packages/deluge/ui/webui/lib/webpy022/request.py", line 131, in <lambda>
    func = lambda: handle(inp, fvars)
  File "/usr/lib/python2.5/site-packages/deluge/ui/webui/lib/webpy022/request.py", line 61, in handle
    return tocall(*([x and urllib.unquote(x) for x in args] + fna))
  File "/usr/lib/python2.5/site-packages/deluge/ui/webui/pages.py", line 321, in POST
    utils.daemon_connect(uri)
  File "/usr/lib/python2.5/site-packages/deluge/ui/webui/utils.py", line 199, in daemon_connect
    webui_plugin_manager.start()
  File "/usr/lib/python2.5/site-packages/deluge/ui/webui/components.py", line 139, in start
    aclient.get_enabled_plugins(self._on_get_enabled_plugins)
  File "/usr/lib/python2.5/site-packages/deluge/ui/client.py", line 361, in async_proxy
    return self.core.call(method_name, *args, **kwargs)
  File "/usr/lib/python2.5/site-packages/deluge/ui/client.py", line 112, in call
    raise deluge.error.NoCoreError("The core proxy is invalid.")

i run gentoo linux and deluge-1.1.0_rc3

the content of /etc/conf.d/deluged is:

DELUGED_USER="root:root"
DELUGEUI_START="true"
DELUGEUI_OPTS="-u web"

please let me know if other informations are needed. thanks.

Change History (4)

comment:1 Changed 12 years ago by anonymous

Not a bug:

Try to get a copy of the auth file from deluge config directory. By default the config directory is ~/.config/deluge

BR;

comment:2 Changed 12 years ago by qxtr01@…

i didn't understand what i should do to fix this problem. i tried adding a user as suggested in http://dev.deluge-torrent.org/wiki/Authentication but the problem remains. i also tried deluge version 1.1.0 but the problem is the very same.

comment:3 Changed 12 years ago by andreamatesi@…

  • Version changed from 1.1.0_RC3 to 1.1.0

same over here... client/server used to work till 1.0.7 recent 1.1.0 broke. I have Ubuntu Server 8.04.1 LTS as 1.1.0 server and Intrepid as 1.1.0 client from the launchpad repos. I've made a deluge user and group with /home/deluge, also I've made the /etc/init.d/deluge-daemon to make it start automatically as a daemon with user deluge and null ui.

here's a paste of my error, took from webui: --Deluge Error-- NoCoreError? : 'The core proxy is invalid.' path : /connect file : /var/lib/python-support/python2.5/deluge/ui/client.py in call, line 111

--Input-- <Storage {'other_uri': , 'uri': 'http://localhost:58846', 'submit': 'Connettiti'}>

--Versions-- WebUi? : 1.1.0r Python 2.5.2 (r252:60911, Jul 31 2008, 17:31:22) [GCC 4.2.3 (Ubuntu 4.2.3-2ubuntu7)]:

--Traceback--

File "/var/lib/python-support/python2.5/deluge/ui/webui/lib/webpy022/webapi.py", line 310, in wsgifunc

result = func()

File "/var/lib/python-support/python2.5/deluge/ui/webui/lib/webpy022/request.py", line 131, in <lambda>

func = lambda: handle(inp, fvars)

File "/var/lib/python-support/python2.5/deluge/ui/webui/lib/webpy022/request.py", line 61, in handle

return tocall(*([x and urllib.unquote(x) for x in args] + fna))

File "/var/lib/python-support/python2.5/deluge/ui/webui/pages.py", line 321, in POST

utils.daemon_connect(uri)

File "/var/lib/python-support/python2.5/deluge/ui/webui/utils.py", line 199, in daemon_connect

webui_plugin_manager.start()

File "/var/lib/python-support/python2.5/deluge/ui/webui/components.py", line 139, in start

aclient.get_enabled_plugins(self._on_get_enabled_plugins)

File "/var/lib/python-support/python2.5/deluge/ui/client.py", line 361, in async_proxy

return self.core.call(method_name, *args, kwargs)

File "/var/lib/python-support/python2.5/deluge/ui/client.py", line 112, in call

raise deluge.error.NoCoreError?("The core proxy is invalid.")

comment:4 Changed 12 years ago by maveyo

  • Resolution set to fixed
  • Status changed from new to closed

First start "deluged" (deluge daemon), then connect with the client.

Note: See TracTickets for help on using tickets.