Opened 12 years ago

Closed 12 years ago

#725 closed bug (Fixed)

Japanese characters cause Deluge to crash

Reported by: howard.browning@… Owned by: andar
Priority: major Milestone:
Component: Unknown Version: 1.1.6
Keywords: Cc:

Description

Hello, Since 1.1.0 rc1 in Windows XP, deluge crashes whenever I try to start a torrent that uses files names in Japanese only(torrent names or file names). When I try to load a torrent in Japanese, the gui window disappears. When I check the task manager, deluged is still running, and when I start up the gui the new torrent is not listed.

If there is even one number or roman letter in the name its ok(though Deluge shows the Japanese characters as boxes with either an x or circles in it). I wish I could be of more help but I'm a simple user with little knowledge of how all this stuff actually works.

Change History (3)

comment:1 Changed 12 years ago by kopi

Similar thing happens to me. Vista Business SP1, Deluge 1.1.0. Crashes on addition of torrents with Chiness characters.

comment:2 Changed 12 years ago by howard.browning@…

  • Version changed from 1.1.0 to 1.1.5

Having the same problem with Deluge 1.1.5. A torrent named or containing files named in all Japanese characters still crashes Deluge. But now, when I load a torrent with mixed Roman and Japanese characters, the Japanese characters are properly displayed instead of the boxes with x's and circles.

comment:3 Changed 12 years ago by howard.browning@…

  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from 1.1.5 to 1.1.6

Japanese characters no longer cause Deluge to crash. Deluge just ignores torrents with all Japanese filenames.

Note: See TracTickets for help on using tickets.