Opened 12 years ago

Closed 12 years ago

#727 closed bug (Fixed)

rm in console ui removes all

Reported by: tiagoboldt@… Owned by: andar
Priority: major Milestone:
Component: Unknown Version: 1.1.0
Keywords: console, ui, rm Cc:

Description

I've upgraded deluge to the latest 1.1.0-1, and when I try to stop and remove a torrent within the console ui, all the torrents are removed from the daemon. I had Torrent 1 downloading and Torrent 2 seeding and when I deleted Torrent 2(rm Torrent 2 <- tab auto completed it), both torrents were removed.

Change History (2)

comment:1 in reply to: ↑ description Changed 12 years ago by scott@…

  • Keywords rm added

Replying to tiagoboldt@…:

I've upgraded deluge to the latest 1.1.0-1, and when I try to stop and remove a torrent within the console ui, all the torrents are removed from the daemon. I had Torrent 1 downloading and Torrent 2 seeding and when I deleted Torrent 2(rm Torrent 2 <- tab auto completed it), both torrents were removed.

Similar problem: Simply typing "rm" at the console without the <torrent-id> argument will remove all torrents in version 1.1.2. If that's the intended behavior then perhaps the usage should look more like "Usage: rm [<torrent-id>]"

Another issue is that when I restart the torrent by re-adding it, it will check, but apparently fails because it starts downloading again at 0%.

comment:2 Changed 12 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

This is fixed in 1.2

Note: See TracTickets for help on using tickets.