Opened 13 years ago

Closed 12 years ago

#732 closed bug (Fixed)

Segfault in UI through "Add Torrents" dialog

Reported by: r0ckarong Owned by: andar
Priority: minor Milestone:
Component: GTK UI Version: 1.1.0
Keywords: segfault, add torrents, dialog, gtkui Cc:

Description

So I'm using 1.1.0 on my Ubuntu 8.10 machine as usual today and I tried to add several torrents at once. Unfortunately I added one torrent twice and tried to remove it.

I get the UI to display me the "add" dialog (not the add to session but "where to store" one) and when I remove one of the torrents via the "Remove" button and then click on another one of the items in the list the UI just segfaults and dies. The daemon keeps running unaffected. Since I don't know how to produce shell output from the GUI alone I can't help with any dumps.

I can reproduce this 100% of the time right now. Sometimes it takes 3 items in the list sometimes I get it to crash with just two.

Change History (1)

comment:1 Changed 12 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

This is fixed.

Note: See TracTickets for help on using tickets.