Opened 15 years ago

Closed 15 years ago

#765 closed bug (WorksForMe)

deluged 1.1.1 fails to start on gentoo

Reported by: marcelocoelho@gmail.com Owned by: andar
Priority: minor Milestone:
Component: Core Version: 1.1.0
Keywords: Cc:

Description

After updating from 1.0.4 to 1.1.1, deluged doesn't start. If I remove the --background option from the start-stop-daemon I get the following error:

 terminate called after throwing an instance of 'boost::python::error_already_set'

I change the default home location to a different location. This also happens with 1.1.0

dev-libs/boost 1.35.0-r2 dev-util/boost-build 1.35.0-r1

Change History (2)

comment:1 by anonymous, 15 years ago

Correction: this happens with version 1.0.5 through 1.1.1, with a updated system from last weekend (24-25 Jan).

Steps to reproduce: [1] remove configuration files [2] activate the web interface in /etc/conf.d/deluged [3] /etc/init.d/deluged start [4] connect to web interface [5] add torrent file [6] deluged crashes

In the forums there is another user with a similar problem: http://forum.deluge-torrent.org/viewtopic.php?f=7&t=14995

Basically, I can't run deluged from any version >1.0.5. It may be caused by dependencies that are too recent

comment:2 by marcelocoelho@gmail.com, 15 years ago

Resolution: worksforme
Status: newclosed

After studying the problem, I discovered I had installed boost-build with python flag disabled. After enabling it, and after recompiling deluge, it worked as it should.

Note: See TracTickets for help on using tickets.