Opened 13 years ago

Closed 12 years ago

#768 closed bug (Fixed)

creating torrents - bugs and improvements

Reported by: waltherbans Owned by: andar
Priority: major Milestone: 1.2.0
Component: Unknown Version: 1.2.0_dev
Keywords: creating torrents Cc:

Description

I create torrents for seeding them, so IMHO deluge should add created torrents to the session by default.

When i click "add torrent to current session" in torrent-creator deluge doesn't remember the path of the file where it created the torrent of but tries to download the file to the default directory.

Adding several trackers (one per line) does not work; only the first line (=one tracker) will be added. In 0.5 adding multiple trackers (one per line) worked.

There's no possibility to save a list of trackers. I (and many others?) always use the same trackers for my own torrents, so it would be great to see them beeing added automatically everytime.

The tracker's ranking is confusing: by default every tracker is set to "0", bringing a tracker "up" sends him to the end of the list. Bringing several trackers "up" results in all of them beeing ranked "1". Klicking on "up" once more counts up the tracker's rank instead of giving it a higher priority (maybe it does, but the ranking is confusing).

Attachments (1)

trackers.png (36.3 KB) - added by waltherbans 13 years ago.
to illustrate the confusing ranking

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by waltherbans

to illustrate the confusing ranking

comment:1 Changed 13 years ago by ari-_-e

Just a comment: a lot of private trackers require you to upload the .torrent and then re-download it before you can start seeding, so the "auto-add" thing might not be the best idea.

comment:2 Changed 13 years ago by anonymous

@ari-_-e: Okay, I didn't knew about that because I don't use private trackers. But I think you agree on my other points?

comment:3 Changed 13 years ago by waltherbans

  • Version changed from 1.1.0 to 1.1.2

comment:4 Changed 13 years ago by anonymous

  • Version changed from 1.1.2 to 1.2.0_dev

comment:5 Changed 12 years ago by anonymous

I'd like these bugs are fixed too.

This is an example of what i'd like for "Adding several trackers" :

If i add three trackers in deluge :

  1. http :tracker.openbittorrent.com:80/announce
  2. http :open.tracker.thepiratebay.org:80/announce
  3. http :denis.stalker.h3q.com:6969/announce

btshowmeinfo should display :

announce url..: http://tracker.openbittorrent.com:80/announce
announce-list.: http://tracker.openbittorrent.com:80/announce|http://open.tracker.thepiratebay.org:80/announce|http://denis.stalker.h3q.com:6969/announce

Deluge's developers, you are fantastic ! Please continue !

comment:6 Changed 12 years ago by andar

  • Milestone set to 1.2.0
  • Resolution set to fixed
  • Status changed from new to closed

It looks like it adds multiple trackers fine at this point. What I have changed is saving the last used trackers list so the next you create a torrent it will have the same tracker list in the Add dialog.

I will not change the tier Up/Down? buttons as they worked as intended. Going Up a tier should move it closer to 0, the highest tier and will be the first tracker the client will try.

Note: See TracTickets for help on using tickets.