Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#773 closed bug (Invalid)

deluged consistently uses far too much CPU time

Reported by: anonymous Owned by: andar
Priority: major Milestone:
Component: Core Version: 1.1.0
Keywords: Cc:

Description

On my system, deluged's CPU consumption tends stay at 100% of one of my CPU cores at least half the time. (on an Athlon64 x2 5000+ with 4GiB of RAM)

I'm attaching RRDTool graphs (gathered by collectd) for the last hour and day to illustrate the problem.

Attachments (6)

rrd2.png (31.7 KB) - added by anonymous 15 years ago.
Cpu usage graph over an hour
rrd.png (30.6 KB) - added by anonymous 15 years ago.
Cpu usage graph over a day
rrd3.png (26.5 KB) - added by anonymous 15 years ago.
Traffic over the same hour (give or take a minute or two)
rrd4.png (24.0 KB) - added by anonymous 15 years ago.
Traffic over the same day (give or take a minute or two)
rrd5.png (24.6 KB) - added by anonymous 15 years ago.
Traffic in packets over the same 24 hours
rrd6.png (25.8 KB) - added by anonymous 15 years ago.
Traffic in packets over the same hour (give or take)

Download all attachments as: .zip

Change History (9)

Changed 15 years ago by anonymous

Cpu usage graph over an hour

Changed 15 years ago by anonymous

Cpu usage graph over a day

Changed 15 years ago by anonymous

Traffic over the same hour (give or take a minute or two)

Changed 15 years ago by anonymous

Traffic over the same day (give or take a minute or two)

Changed 15 years ago by anonymous

Traffic in packets over the same 24 hours

Changed 15 years ago by anonymous

Traffic in packets over the same hour (give or take)

comment:1 Changed 15 years ago by anonymous

Trac's e-mail spam protection varies from terrible to nonexistent, so I'll be following this via RSS.

Ignore the giant traffic spike in the the 24-hour traffic graph. That was me plugging in a laptop and SFTPing a documentary over to it.

comment:2 Changed 15 years ago by markybob

  • Resolution set to invalid
  • Status changed from new to closed

this is a bug in boost 1.35, not deluge. upgrade boost, recompile deluge and it'll go away

comment:3 Changed 15 years ago by anonymous

Thanks for telling me. The Gentoo devs still have versions newer than 1.35.0-r2 masked for testing, so it'd probably have been a while before I got a newer version without you telling me.

Is there a similarly simple explanation for why the deluge GTK+ UI is still hovering around 15% CPU usage now that I'm on boost 1.36?

Note: See TracTickets for help on using tickets.