Opened 13 years ago

Closed 12 years ago

#805 closed bug (Fixed)

ETA calculation is broken when setting some files to 'Do Not Download'

Reported by: peterhoeg Owned by: andar
Priority: minor Milestone:
Component: GTK UI Version: 1.1.2
Keywords: eta calculate calculation ui Cc:

Description

Problem: When calculating ETA the total downloaded size is not only taking the downloaded size of the selected file into consideration but also downloaded size of files set to 'Do Not Download'.

How to reproduce (sizes mentioned are just examples):

a) Start downloading a torrent with two files in it each with a size of 100MB. Total size to download it then 200MB.

b) Wait for more than 100MB of download (example: both files are downloaded 51% - 51MB each, total of 102MB).

c) Set one of the files to 'Do Not Download'

d) Deluge now thinks that since is has already downloaded more than the required 100MB that it is finished and thus stops calculating ETA.

Expected behaviour:

Deluge should only consider what is downloaded on the files not set to 'Do Not Download'.

Change History (2)

comment:1 Changed 13 years ago by peterhoeg

  • Keywords eta calculate calculation ui added

comment:2 Changed 12 years ago by Ghent

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.