Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#807 closed bug (Duplicate)

Customized file names are reset when Deluge is closed and re-opened

Reported by: Legoguy Owned by: andar
Priority: major Milestone:
Component: Unknown Version: other (please specify)
Keywords: Cc: axet@…

Description

Version 1.1.3/1.1.2 Refer to a few posts down in the forum thread: http://forum.deluge-torrent.org/viewtopic.php?f=8&t=15715

I added a bunch of torrents with 1.1.2, in a paused state, then changed all the names of the root folder in the Files tab to / (so that I could seed the torrents I had downloaded with µtorrent, which behaves differently with regards to folder names). Once I did this, I forced re-checking on all of them, and resumed them so they would seed. All was well, then I upgraded to 1.1.3. Upon loading 1.1.3, all of the torrent's folders had been reset to what they were before I renamed them. I renamed most of them to / again, but some of them refused to change the folder name. I restarted Deluge and found that once again everything had lost my folder changes and I still can't rename some of them.

Change History (5)

comment:1 Changed 13 years ago by Legoguy

  • Resolution set to duplicate
  • Status changed from new to closed

oops, sorry, dupe of #760.

comment:2 Changed 13 years ago by andar

I just tried changing individual filenames and the root folder to /.. It all works perfectly after a restart of Deluge.. There is a possibility that the filenames in the resume data changed format as there was a bug fix in libtorrent to fix an issue with the renamed files.

comment:3 Changed 13 years ago by anonymous

that happens not only ween you upgrade deluge. sometimes imidiatly after restart you got previous state, sometimes you got original filename!!

comment:4 Changed 13 years ago by axet

i also confirm that bug for my macmini PPC and macbook pro x86 machines

comment:5 Changed 13 years ago by axet

  • Cc axet@… added
Note: See TracTickets for help on using tickets.