Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#814 closed bug (Fixed)

High CPU usage on large torrents

Reported by: oli@… Owned by: andar
Priority: critical Milestone:
Component: Core Version: other (please specify)
Keywords: cpu Cc: trac@…

Description

I'm using deluge 1.1.3 (Trac doesn't know what was released)

I am downloading a large torrent (approximately 160x 350meg files).

Intermittently deluge swallows a whole core of my processor, and keeps it down for anywhere between a single second and a minute, though the mean average would probably be 3-5 seconds.

If I pause the torrent as this is happening, CPU usage drops off instantly.

I don't think this is UI related as it still happens when minimised to tray.

If you need additional information or traces, shout and I'll attempt to help you out (though you might need to tell me how).

Change History (13)

comment:1 Changed 12 years ago by itsmealso2@…

I am getting the same thing here , running deluge 1.1.3 in ubuntu jaunty jaguar (9.04 Alpha) . I am seeding a 2.2GB torrent and d/Ling a 583mb torrent . it apears to be deluged that is grabing the CPU periodicly .

comment:2 Changed 12 years ago by dottomi@…

Yes, its deluged. Happens to me too. I'm on Gentoo. It takes up whole processor from time to time for around 10 seconds and freezes everything else.

comment:3 Changed 12 years ago by oli@…

Yeah sorry I meant deluged.

If it's at all relevant, I'm running in classic mode.

comment:4 Changed 12 years ago by itsmealso2@…

doing some testing I have found that it is related to the size of the torrent being downloaded . It does not seem to occur if you are seeding only regardless of size , when downloading only it occurs with fles of 500mb or larger ( the lower limit may be smaller ) it did not occur with a filesize of 255mb but did occur with a 535mb file .

comment:5 Changed 12 years ago by anonymous

I am experiencing the same issue... I have one core that loads 100% .. And I'm seeding a 7gb file. Very annoying when I am trying to compile. I shut down deluge to compile.

comment:6 follow-up: Changed 12 years ago by guiohm

  • Milestone changed from 1.1.3 to 1.2.0
  • Version changed from other (please specify) to 1.2.0_dev

Same thing as above with svn rev. 4851 & 4856 (1.2.0_dev). Nothing shows up in deluged debug info.

x86_64, python-2.5.4-r2, ext4 filesystem.

comment:7 in reply to: ↑ 6 Changed 12 years ago by guiohm

  • Milestone changed from 1.2.0 to 1.1.3
  • Version changed from 1.2.0_dev to other (please specify)

Sorry, I hadn't search enough, problem solved for me by upgrading boost to 1.36 (cf Ticket #603).

comment:8 Changed 12 years ago by guiohm

  • Cc trac@… added

Well, sorry again, the problem is still here. Only one deluged process do that. It is always the second of the three consecutive PID.

This also happens when upload only of one torrent composed of 95*47.7Mo.

Same behavior with 1.1.3 and 1.1.4. All compiled against boost 1.36 via Gentoo ebuilds.

I don't have any Python skills yet, but you can tell me what I can do to help.

comment:9 follow-up: Changed 12 years ago by oli@…

I've actually found the problem has disappeared with my move to Python 2.6.

It might be a coincidence but another Python app that was using too much CPU has started behaving too. Might be something to explore.

comment:10 in reply to: ↑ 9 Changed 12 years ago by lovinglinux

Replying to oli@…:

I've actually found the problem has disappeared with my move to Python 2.6.

It might be a coincidence but another Python app that was using too much CPU has started behaving too. Might be something to explore.

I don't think is a coincidence. I removed Python 2.5 after reading this, now I have less CPU usage and my system is more responsive, while running Deluge or not. Thanks for the tip.

comment:11 Changed 12 years ago by oli@…

  • Resolution set to fixed
  • Status changed from new to closed

It is most odd. In every benchmark comparison between 2.5 and 2.6, 2.5 does better (in that it completes the tests faster) but I guess this goes to show that languages' overall runtime performance cannot be accurately compared with just benchmarks.

I hope v3 is similarly pleasing.

/me tips his hat in the direction of the Python devs

comment:12 Changed 12 years ago by anonymous

  • Milestone 1.1.3 deleted

Milestone 1.1.3 deleted

comment:13 Changed 11 years ago by alisazhao2009

links of london jewelry discount , famous for its sweetie and friendship bracelets. Christian Audigier designer, ed hardy , is a brand of Christian Audigier, and now are favored in the moderning world as a mark of its nice tatoo.

Note: See TracTickets for help on using tickets.