Opened 13 years ago

Closed 13 years ago

#825 closed feature-request (Fixed)

No Windows Version

Reported by: jerrac@… Owned by: andar
Priority: major Milestone:
Component: Unknown Version: 1.1.0
Keywords: Cc:

Description

I was searching for a new bittorrent client to try on Windows and found Deluge. The site says there is a Windows version, but there are no downloads on the Download page for it.

I did some research, and it looks like the person who was doing to Windows version quit, which explains why there is no current download.

The problem is that it now looks like Deluge is lying about having a Windows version.

May I suggest that the site not say that there is a Windows version until there is someone maintaining it again?

Change History (1)

comment:1 Changed 13 years ago by Damn

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.