Opened 15 years ago

Closed 14 years ago

#846 closed bug (WorksForMe)

high cpu with many torrents

Reported by: eric.nathan.hickman@gmail.com Owned by: andar
Priority: major Milestone:
Component: Unknown Version: 1.1.4
Keywords: high cpu Cc:

Description

used up 100% of cpu with 230 torrents listed ready to be downloaded even with all downloads (only 5) throttled to 1 kb. became unresponsive for 4 seconds at a time, though still usable, very annoying. and disrupted other work on computer as cpu was maxed out.

Change History (5)

comment:1 Changed 15 years ago by anonymous

I have a similar problem in 1.1.9. Basically, the more torrents I have on display, the bigger the CPU spike. With around 300+ torrents, the CPU spikes are around 20%, I've seen them go to 50% CPU total with 900+ torrents. That's a half core and a full core respectively in a Core2Duo system.

comment:2 Changed 15 years ago by anonymous

I have experienced similar, however i am using a remote deluge server with the local gtk client. The server is fine, but the client is currently maxing out with 6 downloading, 4 seeding, 2 queued and 34 paused. The client is 1.1.9 running on windows, while the server is 1.1.4 running on linux.

comment:3 Changed 14 years ago by andar

Is this still an issue with 1.2?

comment:4 follow-up: Changed 14 years ago by andar

  • Status changed from new to pending

comment:5 in reply to: ↑ 4 Changed 14 years ago by enhickman

  • Resolution set to worksforme
  • Status changed from pending to closed

Replying to andar: Currently from Deluge 1.2, Ubuntu Karmic, I have 241 torrents queued and 10 open with no bandwidth limiting and i haven't been able to reproduce the bug from 1.1.4. My processor seems to be used at 30-60 percent on average. I have an amd athlon xp 2500+ which is the same system that originated this bug previously. At no time has Deluge become unresponsive. The amount of processor still seems to be related to the amount of torrents being watched in the window if I show all 250 torrents, processor jumps between 99% and 30%. If I show only the active torrents the processor sits at about 30%. I would say it passed my test so its fixed for me.

I am the originator of this bug report had to re-signup because none of my passwords seemed to be working = )

Note: See TracTickets for help on using tickets.