Opened 12 years ago

Closed 7 years ago

#858 closed bug (WorksForMe)

Input-output error on uncomplete downloads after restarting deluge EXT4

Reported by: deluge@… Owned by: andar
Priority: critical Milestone:
Component: Core Version:
Keywords: Cc:

Description

When using EXT4, if I close Deluge (1.4 and 1.5) then start Deluge again (Full close, ie: File-->Close) when I restart Deluge any torrents which have not completed will attempt to resume. Most often, any resumed torrents will go to "Error" status. Details say "Input/output error". If do a "force recheck" on the torrent it will error out almost immediately (ususaly at less than 1%, even if it was at 98% completed before the restart.)

Files are being written to EXT4 file system, 2.6.28 kernel, X86_64

I have tried checking the FS, no corruption.

The only solution I've found is to completely delete the data and start the download agian.

Change History (7)

comment:1 Changed 12 years ago by deluge@…

It seems that if I pause any incomplete downloads for 2 to 3 minutes before shutting down Deluge, that the file corruption does not occur. I have tried this on 6 or 7 different occasions and it has worked. I'm guessing maybe EXT4 has time to flush everything during that time. Simply pausing and then closing Deluge immediately still results in corruption about 50% of the time.

comment:2 Changed 12 years ago by mason.larobina@…

  • Version changed from 1.1.5 to 1.1.6

I am having this same problem here on an EXT3 file system.

I am using deluge-1.1.6 on Gentoo linux. I can also confirm that by pausing my torrents for a number of minutes before closing deluge my torrents resume perfectly. In some instances I also get a similar error to "Missing files or directories" when I have closed deluge after recently adding a torrent. Without waiting after pausing torrents and I restart deluge "Input/output error" errors will result 100% of the time.

I find also that if I close deluge just after telling all my torrents to pause and restart too soon after the pause request is lost and all torrents resume as if I had never asked. I'm assuming that configuration file changes also suffer from this lack of flushing.

~ $ uname -srmv Linux 2.6.27-gentoo-r8 #6 SMP Sat Mar 14 14:48:56 WST 2009 x86_64

My python version is 2.5.2-r7 built with the following use-flags: berkdb gdbm ncurses readline sqlite ssl threads xml -build -doc -elibc_uclibc -examples -ipv6 -tk -ucs2 -wininst

comment:3 Changed 11 years ago by andar

Is this still a problem with 1.2?

comment:4 Changed 11 years ago by mason-l

I forgot my password so I had to re-register.

This problem was solved immediately after selecting "Use full allocation" instead of "Use compact allocation".

comment:5 Changed 11 years ago by andar

  • Resolution set to worksforme
  • Status changed from new to closed

Ok. I am going to close this bug. If this turns out to still be a problem, please re-open.

comment:6 Changed 7 years ago by rpgmaker

  • Resolution WorksForMe deleted
  • Status changed from closed to reopened
  • Version changed from 1.1.6 to 1.3.6

This is still present for me on Deluge 1.3.6, not downloading just to ext4 but on ntfs too. That's mostly when it happens for me. I will try the full allocation workaround and report back but this bug still exists.

comment:7 Changed 7 years ago by Cas

  • Resolution set to WorksForMe
  • Status changed from reopened to closed
  • Version 1.3.6 deleted

Please create a new ticket with full details of the issue you are seeing and reference this bug

Contributing/BugReporting#CollectBugInformation

Note: See TracTickets for help on using tickets.