Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#86 closed bug (Invalid)

upgrade of the nightly packages kills download queue

Reported by: deluge-trac@… Owned by: markybob
Priority: major Milestone:
Component: Core Version: 0.6.0svn
Keywords: Cc:

Description

whenever one of the nightly packages is upgraded and the deluged daemon is restarted, the torrent queue is empty again.

Attachments (1)

torrent_pickle.py (193 bytes) - added by deluge-trac@… 13 years ago.
make torrents.state file understandable

Download all attachments as: .zip

Change History (7)

comment:1 Changed 13 years ago by andar

  • Component changed from 0.5.x to core
  • Resolution set to invalid
  • Status changed from new to closed

These are in-development builds.. Of course stuff will break every now and then. I have broke the torrents.state file multiple times now. This is not a bug.

comment:2 Changed 13 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

andar, it seems to me you have a very weird standard as to what constitutes a bug. I am well aware that the nightlies are not supposed to be stable and that they are likely to have bugs. I am not complaining. But my understanding is that the nightlies are published so that errors can be found and fixed. Marking problems as invalid just because "stuff will break every now and then" does not help this at all. This is a reproducible problem.

comment:3 Changed 13 years ago by andar

  • Resolution set to invalid
  • Status changed from reopened to closed

The torrents.state file is not compatible between some revisions. I usually state in the commit log when I break torrents.state compatibility. Please review the log before upgrading if you don't want your state to break.

Changed 13 years ago by deluge-trac@…

make torrents.state file understandable

comment:4 Changed 13 years ago by deluge-trac@…

Andrew let me into a "secret" today that I want to share with others who might be reading this report. The download queue is usually saved to ~/.config/deluge/torrents.state. While it is plain text, it is cumbersome to read. The following will give you more readable output.

comment:5 Changed 13 years ago by andar

The file is actually stored in ~/.config/deluge/state now

comment:6 Changed 13 years ago by anonymous

yes, thanks for pointing that out. If that file does not contain what you are looking for and your previous deluge installation was about a month old, try the location I gave above.

Note: See TracTickets for help on using tickets.