Opened 15 years ago

Closed 14 years ago

#869 closed bug (Duplicate)

concurrent downloads using same name are not handled

Reported by: caramba_bk@yahoo.com Owned by: andar
Priority: minor Milestone:
Component: libtorrent Version:
Keywords: Cc:

Description

There are sometimes two distinct torrents using the same download name, probably providing largely the same content, although not exactly identical. Deluge doesn't seem to handle this, so all files from both torrents are merged into a single download directory. Also, when one of the torrents finish, the directory might be moved and so causes the remaining torrent to fail when it has nowhere to continue writing its files.

Deluge should handle this situation, at least by appending a ".[n]" to a duplicate directory name before it is created. Like numbered backups for the cp command. This assignment must be atomic.

Change History (3)

comment:1 by Calum, 14 years ago

Component: corelibtorrent

comment:2 by Calum, 14 years ago

Priority: majorminor
Version: 1.1.5

comment:3 by Calum, 14 years ago

Resolution: duplicate
Status: newclosed

duplicate of #856

Note: See TracTickets for help on using tickets.