Opened 11 years ago

Closed 10 years ago

#879 closed bug (Invalid)

Upnp forwards aren't closed on exit

Reported by: Nick Owned by: andar
Priority: major Milestone:
Component: libtorrent Version: 1.1.6
Keywords: Cc:

Description

After exiting Deluge, the upnp forwards in the router remain open. I went into my router one day to fine about 20 forwards left open from Deluge that I had to manually remove. I've tested some other applications that use upnp and they don't seem to have a problem closing their forwards, so I don't think it's a firmware problem. I've also been able to reproduce this on the stock Linksys firmware that came with the router as well as DD-wrt which is what I'm using now.

Using Deluge 1.1.6 on Ubuntu 9.04

Change History (9)

comment:1 Changed 11 years ago by Skidmarks

I can confirm this. I had this problem in 1.1.5 and now in 1.1.6 on both Ubuntu 8.10 and 9.04 (x64). Router is running tomato firmware.

comment:2 Changed 11 years ago by andar

  • Status changed from new to pending

Is this still a problem with the latest libtorrent (0.14.7)?

comment:3 Changed 11 years ago by Nick

  • Status changed from pending to new

Still a problem with libtorrent-rasterbar 0.14.7

comment:4 Changed 10 years ago by Cas

  • Status changed from new to pending

Nick whats the latest on this, does latest 0.14.10 or 0.15 resolve this?

comment:5 Changed 10 years ago by Nick

  • Status changed from pending to new

Still a problem with 0.14.10. I have not tested 0.15 yet.

comment:6 Changed 10 years ago by andar

  • Component changed from core to libtorrent

comment:7 Changed 10 years ago by Nick

Looks like this has been reported upstream as well. http://code.google.com/p/libtorrent/issues/detail?id=66

comment:8 Changed 10 years ago by Nick

I tested Deluge 1.3.0 with libtorrent-rasterbar-0.15.4 which has the fix from the above bug report but I am still able to reproduce this problem. Does Deluge need to explicitly remove the forward? (Perhaps it already does this, I don't know.)

comment:9 Changed 10 years ago by Cas

  • Resolution set to invalid
  • Status changed from new to closed

This is all down to libtorrent. Why not reopen the lt bug instead of posting here.

I am closing this ticket as an lt bug ticket now exists and nothing can be done by deluge devs.

Note: See TracTickets for help on using tickets.