Opened 12 years ago

Closed 11 years ago

Last modified 4 years ago

#895 closed bug (Duplicate)

Deluge shows only halves of icons in the tree area

Reported by: neptunia@… Owned by: andar
Priority: minor Milestone: 2.x
Component: GTK UI Version: 1.3.0_dev
Keywords: Cc:

Description

In Deluge 1.1.6 only a half of each icon is visible in the tree area. See the screenshot.

Attachments (3)

shot-Deluge.png (55.9 KB) - added by neptunia@… 12 years ago.
Screenshot
screenshot-Deluge.png (46.6 KB) - added by Anixx 12 years ago.
This is how it looks for me now: even the word 'error' is barely visible. The same problem not only in the tree but also in the preferences dialog where the words lean to the left side.
gconf-interface.png (78.4 KB) - added by Anixx 12 years ago.
GConf-editor with the same settings, for comparison.

Download all attachments as: .zip

Change History (24)

Changed 12 years ago by neptunia@…

Screenshot

comment:1 Changed 12 years ago by andar

This is due to the fact that we cannot know the indentation level that a gtk theme uses for treeviews. We assume the default size and in this case it's cutting off some of the icons.

comment:2 Changed 12 years ago by Cas

  • Resolution set to wontfix
  • Status changed from new to closed

comment:3 Changed 12 years ago by Anixx

  • Component changed from other to gtkui
  • Resolution wontfix deleted
  • Status changed from closed to reopened

Why wontfix? In previous release of Deluge there was no such problem.

Changed 12 years ago by Anixx

This is how it looks for me now: even the word 'error' is barely visible. The same problem not only in the tree but also in the preferences dialog where the words lean to the left side.

comment:4 Changed 12 years ago by damoxc

What GTK theme are you using?

comment:5 Changed 12 years ago by Anixx

Different. The last screenshot is QtCurve?, but the bug appears in any theme.

comment:6 Changed 12 years ago by damoxc

You don't have any .gtkrc customisations at all do you? It's working fine for me with all my themes.

Also is this existent in 1.2, or git master?

Changed 12 years ago by Anixx

GConf-editor with the same settings, for comparison.

comment:7 Changed 12 years ago by Cas

  • Priority changed from major to minor

I haven't noticed anything here either. what os and what version of deluge?

comment:8 Changed 12 years ago by Anixx

You don't have any .gtkrc customisations at all do you?

Only those with Gnome customization utilities. No manual changes.

what os and what version of deluge?

I have experienced this with both Ubuntu and Suse 11.2 and Deluge starting with 1.1.6. With earlier versions there was no such problem.

comment:9 Changed 12 years ago by Anixx

Currently using Deluge 1.2.9 and OpenSUSE 11.2

comment:10 Changed 12 years ago by damoxc

Deluge 1.2.9 doesn't exist?

comment:11 Changed 12 years ago by Anixx

I use the git build from OBS (Deluge 1.2.900-dev), but with 1.2.2 version the problem is the same.

comment:12 Changed 12 years ago by Anixx

Latest version I tried was 1.2.900git20100411-1.1 (x86_64)

comment:13 Changed 12 years ago by Anixx

Try to run gnome-color-chooser and select the appearance to 'compact'. Maybe this could affect the Deluge appearance.

comment:14 Changed 12 years ago by Cas

  • Version changed from 1.1.6 to 1.3.0_dev

comment:15 Changed 12 years ago by damoxc

I'm not seeing this compact setting??

http://www.imagebam.com/image/16f0ff76050754

comment:16 Changed 12 years ago by damoxc

Ah ignore me, its in the dropdown.

comment:17 Changed 12 years ago by damoxc

Ah yes I can confirm that that is what is causing it.

comment:18 Changed 12 years ago by Cas

  • Milestone set to 1.3.0

comment:19 Changed 11 years ago by damoxc

  • Milestone changed from 1.3.0 to 1.4.0

comment:20 Changed 11 years ago by johnnyg

  • Resolution set to duplicate
  • Status changed from reopened to closed

Marking this as a duplicate of #1349 as it contains more information on the problem.

comment:21 Changed 4 years ago by Cas

  • Milestone changed from 2.0.x to 2.x

Milestone renamed

Note: See TracTickets for help on using tickets.