Changes between Version 4 and Version 5 of Installing


Ignore:
Timestamp:
02/14/2009 05:31:31 AM (13 years ago)
Author:
johnnyg
Comment:

updated to include links to child pages

Legend:

Unmodified
Added
Removed
Modified
  • Installing

    v4 v5  
    11= Installing Deluge = 
    2  
    3 [[PageOutline(2,,inline)]] 
    42 
    53There are various options for installing Deluge. You can either install the appropriate packaged release or executable for your operating system, or you can build Deluge from source code. Generally, if a package is available for your system it is best to use it rather than build from source. 
    64 
    7 == Installing on Linux == 
    8  
    9 [wiki:Installing/Linux] 
    10  
    11 To install Deluge on Linux, head to the [http://www.deluge-torrent.org/downloads.php downloads page] and select the distribution you use. Some distributions (such as Ubuntu) may have packages available for multiple versions. For example, if you select Ubuntu you may see packages for 7.10 Gutsy Gibbon, 8.04 Hardy Heron and 8.10 Intrepid Ibex. Be sure to select the package which corresponds to the version you have installed. 
    12  
    13 If you are using a 32 bit computer and operating system, you will need to select the package for i386 systems. 
    14  
    15 If you are using a 64 bit computer and operating system, select the package for x86_64 systems. 
    16  
    17 Once you have found the correct package for your system, download it to a convenient location on your computer. On most systems you can install the package simply by double-clicking on the downloaded file to open it with your distribution's package management software and following the on-screen instructions. 
    18  
    19 == Installing on Windows == 
    20  
    21 [wiki:Installing/Windows] 
    22  
    23 To install Deluge on Windows, head to the [http://www.deluge-torrent.org/downloads.php downloads page] and select Windows from the list of download options. You will be presented with the option to download Deluge for 32-bit or 64-bit versions of Windows.  
    24  
    25 If you are unsure which version you need, you can find out by right-clicking the My Computer icon and selecting Properties. Under the System section of the General tab, you will see your Windows version. If this includes x64 Edition you will need to download the 64-bit version of Deluge, otherwise download the 32-bit version. If you are still unsure, download the 32-bit version. 
    26  
    27 == Installing From Source == 
    28  
    29 [wiki:Installing/Source Installing Deluge from Source] 
    30  
    31 == Installing on FreeBSD == 
    32  
    33 [wiki:Installing/FreeBSD] 
    34  
    35 To install Deluge in FreeBSD it is similar to doing it from source. This example will be pulling from the 1.1.0_RC branch. First you need subversion for svn access: 
    36  
    37 {{{ 
    38 cd /usr/ports/devel/subversion; make install clean 
    39 }}} 
    40  
    41 Before you get other dependencies, you need to compile boost with python support. Do not use devel/boost-python, for some reason this doesn't work. We will compile boost manually like this: 
    42  
    43 {{{ 
    44 cd /usr/ports/devel/boost; make -DWITH_PYTHON install clean 
    45 }}} 
    46  
    47 Note that "-DWITH_PYTHON" is essential here. 
    48  
    49 There are several other dependencies that need to be met as well including Python and other libraries. If you have the portinstall package installed you can do: 
    50  
    51 {{{ 
    52 portinstall python25 py-setuptools py-xdg py-gobject py-gtk2 librsvg2 
    53 }}} 
    54  
    55 or 
    56  
    57 {{{ 
    58 cd /usr/ports/devel/python25; make install clean; 
    59 cd /usr/ports/devel/py-setuptools; make install clean; 
    60 cd /usr/ports/devel/py-xdg; make install clean; 
    61 cd /usr/ports/devel/py-gobject; make install clean; 
    62 cd /usr/ports/x11-toolkits/py-gtk2; make install clean; 
    63 cd /usr/ports/graphics/librsvg2; make install clean; 
    64 }}} 
    65  
    66 Note that this will install dependencies for these packages as well. This is normal. This is the only time you will need to worry about all of these packages. You can upgrade Deluge without having to touch these. Also note that when you install librsvg2, you do NOT want to enable Mozilla support unless you are using Firefox 2.x. 
    67  
    68 After the dependencies are met, you can get Deluge from the svn. This will copy Deluge from the svn to a directory called deluge. 
    69  
    70 {{{ 
    71 svn co http://svn.deluge-torrent.org/branches/1.1.0_RC deluge 
    72 }}} 
    73  
    74 Once that finishes, just: 
    75  
    76 {{{ 
    77 cd deluge 
    78 }}} 
    79  
    80 Then build: 
    81  
    82 {{{ 
    83 python setup.py build 
    84 }}} 
    85  
    86 Then either su or sudo: 
    87  
    88 {{{ 
    89 python setup.py install 
    90 }}} 
    91  
    92 And that's it. Drop back to a regular user and start having fun with Deluge! If I missed something regarding a FreeBSD install, please contact !AlmightyOatmeal on Freenode. 
     5[wiki:Installing/Linux Installing Deluge on Linux][[BR]] 
     6[wiki:Installing/Windows Installing Deluge on Windows][[BR]] 
     7[wiki:Installing/FreeBSD Installing Deluge on FreeBSD][[BR]] 
     8[wiki:Installing/Source Installing Deluge from Source][[BR]]