Opened 8 years ago

Closed 2 years ago

Last modified 2 years ago

#1032 closed feature-request (Fixed)

Error-out if downloaded torrent data is suddenly missing

Reported by: s0undt3ch Owned by: Cas
Priority: critical Milestone: 1.3.13
Component: Core Version: master (git)
Keywords: Cc: non7top@…, luther138@…

Description

When a seeding torrent data is moved on the file-system from outside deluge, deluge starts thinking it's a new torrent and starts downloading it again(at least within server restarts). The correct behaviour would be to error the torrent giving it a meaningful status message like "Downloaded torrent data not found" or something like this, and if the user actually wants to re-download the torrent, have him resume it.

Change History (19)

comment:1 Changed 8 years ago by andar

  • Milestone changed from 1.2.0 to 1.3.0
  • Version 1.1.9 deleted

comment:2 Changed 8 years ago by damoxc

  • Milestone changed from 1.3.0 to 1.4.0

comment:3 Changed 7 years ago by Cas

  • Type changed from bug to feature-request

Changed to feature request as it is not a bug per-se

comment:4 Changed 7 years ago by Cas

  • Summary changed from Force error when torrent data is moved from outside deluge to Error-out if downloaded torrent data is suddenly missing

comment:6 Changed 6 years ago by s0undt3ch

  • Owner changed from andar to s0undt3ch
  • Status changed from new to assigned
  • Version set to git master

A fix is being cooked...

comment:7 Changed 6 years ago by non7top

  • Cc non7top@… added

comment:8 Changed 5 years ago by SisyphusMyth

That would be a great "fix". If you need help implementing it, please contact me.

comment:9 Changed 5 years ago by luther138

  • Cc luther138@… added
  • Milestone changed from 1.4.0 to 1.3.x
  • Type changed from feature-request to bug

Is this still being looked into? Rebooting a machine that has a failed mount point, will cause all of the seeding torrents to redownload to a new location. This can be very damaging to a user without an unlimited data plan (as well as damaging to a users ratio on private trackers).

While this isn't the exact case this bug describes I believe that a solution to one would be a solution to the other.

I would consider this more of a bug then a feature-request, torrents shouldn't start downloading to a new location without a warning or user interaction.

SisyphusMyth?: Since nobody has looked at this in 15 months I am

sure they would be glad to have your help.

Thanks.

comment:10 follow-up: Changed 5 years ago by Cas

  • Milestone changed from 1.3.x to 1.4.0
  • Type changed from bug to feature-request

Please do not change ticket settings.

comment:11 in reply to: ↑ 10 Changed 5 years ago by luther138

Replying to Cas:

Please do not change ticket settings.

My sincere apologies.

I am assuming from your terse retort that you don't agree.

A seeding torrent redownloading to a new location could incur charges to a user who's ISP has a usage-based pricing plan. Costing users extra money seemed like a bug.

Thanks for your attention to this, I look forward to having it as a feature in 1.4.0

-Luther

comment:12 Changed 4 years ago by Yoshi8765

Is this feature request still being worked on? I noticed this today and it would be nice if deluge could work similar to utorrent: It would stop a seeding torrent if files are missing and notify you with an error. The forum threads I've found regarding this has died off a while ago in the middle of discussion...

comment:13 Changed 4 years ago by mauromi

+1 for this feature, i need that :) Thanks

comment:14 Changed 3 years ago by Cas

For reference, duplicate/related tickets: #1487, #2006, #2385, #2456

comment:15 Changed 3 years ago by Cas

  • Owner changed from s0undt3ch to Cas
  • Priority changed from major to critical

comment:16 Changed 3 years ago by Cas

  • Milestone changed from 1.4.0 to 2.0.0

comment:17 Changed 2 years ago by m!nus

Any ideas how this can be fixed? One could compare the saved state of the torrent with the files on disk, I guess.

comment:18 Changed 2 years ago by Cas

  • Milestone changed from 2.0 to 1.3.13
  • Resolution set to Fixed
  • Status changed from assigned to closed

I think I have finally got a robust fix implemented in 1.3-stable: [0ab7ebd0177f281e]

It would be helpful to get feedback on this before I make another release.

comment:19 Changed 2 years ago by m!nus

Tried on 2.0-dev. After starting with a not mounted disk the torrent is in error state wiht status showing "Unable to locate Download Folder!". Works!

Note: See TracTickets for help on using tickets.