Opened 5 months ago

Closed 3 months ago

#2991 closed bug (Fixed)

Proxy settings not displayed correctly

Reported by: NewRush-inPirate Owned by:
Priority: major Milestone: 1.3.15
Component: Unknown Version: 1.3.14
Keywords: Cc:

Description

All my proxy settings are displayed like they're set to "None", even though the proxy seems to be used.

OS: Arch Linux

Change History (5)

comment:1 Changed 5 months ago by Cas

  • Milestone changed from needs verified to 1.3.15

The peer section should contain your proxy settings no? This is by design, I should update the release notes with that information and there is a forum thread with same question and I referenced the changes made in #2149.

I am open to suggestions of better informing the user about this but the scope for code changes in 1.3 is very minimal and I have reworked the proxies tab for upcoming 2.0.

comment:2 Changed 5 months ago by NewRush-inPirate

I dunno, the peer section is empty for me.

comment:3 Changed 5 months ago by Cas

Hmm ok, might need to look at the code again then. It might be that I copy the settings to all the proxies to better indicate that libtorrent releases only have one proxy setting now.

comment:4 Changed 3 months ago by Cas

So I have made some changes and applied them to 1.3-stable: [d977915f3208]

comment:5 Changed 3 months ago by Cas

  • Resolution set to Fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.