Opened 11 years ago

Closed 11 years ago

#1210 closed bug (Fixed)

Deluge does not correctly save the sort column and order in the files tab

Reported by: squisher Owned by:
Priority: minor Milestone: 1.3
Component: GTK UI Version: 1.2.3
Keywords: Cc:

Description

Deluge doesn't correctly save the sort column and order. Just try to select ascending sorting on the file name. Next time deluge is started, no column will be sorted.

The problem is the incorrect check of the return values of set_sort_column_id(). A simple if is used, which evaluates 0 as False, but 0 is a valid column id _and_ sort order.

Attachments (1)

0001-Correctly-store-and-restore-the-sort_column_id.patch (1.3 KB) - added by squisher 11 years ago.
Patch to correctly check the return values of get_sort_column_id(). Not tested, sorry.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by squisher

Patch to correctly check the return values of get_sort_column_id(). Not tested, sorry.

comment:1 Changed 11 years ago by squisher

Patch tested on 1.2.3. Fixes the problem, no issues here.

comment:2 Changed 11 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

Applied in master.

Thanks.

Note: See TracTickets for help on using tickets.