Opened 11 years ago

Closed 10 years ago

Last modified 5 years ago

#1457 closed bug (WorksForMe)

[win32] Tracker error when BlockList plugin is used

Reported by: R4cOOn Owned by:
Priority: minor Milestone:
Component: libtorrent Version: 1.3.1
Keywords: Cc:

Description

I'm using Deluge 1.3.1 (latest release).

When I don't use the BlockList? plugin everything works fine.

As soon as import the blocklist then tracker status goes from "OK" to "Error: The system detected an invalid pointer address in attempting to use a pointer argument in a call". Then I can't get any connection anymore :-(

I tried running as administrator but that didn't change anything. I tried only importing the list after Deluge loaded but that didn't solve the issue either.

Machine: Win7 x64 Deluge: 1.3.1

Change History (4)

comment:1 Changed 11 years ago by Cas

  • Component changed from windows to plugin
  • Summary changed from Tracker status: "Error: The system detected an invalid pointer address in attempting to use a pointer argument in a call" when BlockList plugin is used to [win32] Tracker error when BlockList plugin is used
Tracker status: "Error: The system detected an invalid pointer address in attempting to use a pointer argument in a call" when BlockList plugin is used

You should not put the entire error message in the title.

It would be handy to have debug logs for this.

comment:2 Changed 10 years ago by Cas

  • Component changed from plugin to libtorrent
  • Priority changed from major to minor
  • Status changed from new to pending

Can you retest with 1.3.2 please as it uses a newer version of libtorrent.

comment:3 Changed 10 years ago by Cas

  • Resolution set to worksforme
  • Status changed from pending to closed

comment:4 Changed 5 years ago by Cas

  • Milestone 1.3.x deleted

Milestone deleted

Note: See TracTickets for help on using tickets.