Opened 10 years ago

Closed 10 years ago

#1824 closed bug (Fixed)

False (?) authentication failure message

Reported by: shnurapet Owned by: s0undt3ch
Priority: minor Milestone: Future
Component: GTK UI Version: master
Keywords: ConnectionManager Cc:

Description

I have two separate daemons in WLAN. When double-clicking on a daemon in the Connections Manager while being connected (and viewing) to another one, a message shows up saying:

Failed To Authenticate
'ConnectionManager' object has no attribute 'connection_manager'

It works the second time I double-click (or when I disconnect from the daemon being viewed first).

This is git master on Fedora 14 x86_64 as of today.

Attachments (2)

Снимок-1.png (10.2 KB) - added by shnurapet 10 years ago.
scr.png (10.2 KB) - added by shnurapet 10 years ago.

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by shnurapet

comment:1 follow-up: Changed 10 years ago by shnurapet

Also an empty message "Failed To Authenticate" is shown if clicked "Connect" to a daemon when it is not running.

comment:2 follow-up: Changed 10 years ago by s0undt3ch

  • Keywords ConnectionManager added
  • Owner set to s0undt3ch
  • Status changed from new to accepted

Is this running current master? Also could you re-attach the screenshot in englisn locale? Trac is now allowing me to download it.

comment:3 Changed 10 years ago by s0undt3ch

Sorry, s/is now/is not/

comment:4 in reply to: ↑ 2 Changed 10 years ago by shnurapet

Replying to s0undt3ch:

Is this running current master? Also could you re-attach the screenshot in englisn locale? Trac is now allowing me to download it.

Yes, of course. Sorry for that. This is master as of April 30th (the latest at the moment of filing this ticket).

Changed 10 years ago by shnurapet

comment:5 Changed 10 years ago by s0undt3ch

Ok. So this happens when connected to a daemon and trying to connect to another one. I'll investigate.

comment:6 Changed 10 years ago by s0undt3ch

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in current master.

comment:7 in reply to: ↑ 1 ; follow-up: Changed 10 years ago by shnurapet

  • Resolution fixed deleted
  • Status changed from closed to reopened

Sorry for reopening. This one still occurs:

Replying to shnurapet:

Also an empty message "Failed To Authenticate" is shown if clicked "Connect" to a daemon when it is not running.

Though it connects to the daemon and all I gotta do it to click that message away.

comment:8 in reply to: ↑ 7 Changed 10 years ago by s0undt3ch

  • Status changed from reopened to accepted

Replying to shnurapet:

Sorry for reopening. This one still occurs:

Replying to shnurapet:

Also an empty message "Failed To Authenticate" is shown if clicked "Connect" to a daemon when it is not running.

Though it connects to the daemon and all I gotta do it to click that message away.

Weird. You're only allowed to connect to non-running daemons if it's entry in the connection manager is for a localhost daemon.

What's happening on my end is that I'm allowed to click connect for such host entries, but all I'm getting is a connection refused, which is not what's intended, ie, if it's a localhost entry, and it's not running, start it and connect to it. If it's running, just connect to it.

So, although I'm unable to reproduce your issue with a clean config, part of what the connection manager should be doin' it's not. So, I'll keep this open until I fix that. Maybe then I'm able to reproduce your issue.

comment:9 Changed 10 years ago by s0undt3ch

Also, which locale are you using?

comment:10 Changed 10 years ago by s0undt3ch

  • Resolution set to fixed
  • Status changed from accepted to closed

Please try master as of a7bd9531698ae47b48acbcefb60c26f85e397dc6.

Re-open if still happening please.

Note: See TracTickets for help on using tickets.