Opened 4 years ago

Closed 4 years ago

#2456 closed bug (Duplicate)

Torrents failing hash check should not re-download automatically

Reported by: skomorokh Owned by:
Priority: minor Milestone: Future
Component: Unknown Version: 1.3.6
Keywords: Cc:

Description

Wound up using a lot of bandwidth when a mountpoint didn't come online soon enough and all the torrents on that drive reset to 0%.

I can't think of any situation where I'd want to re-download something I was previously seeding without manual confirmation:

  • if my storage is unavailable for some reason I want a chance to rectify
  • if a file was corrupted by something the hash check gives me valuable info about my failing drive and I will totally not notice if it just silently re-fetches the missing chunks
  • if I delete something I still had open in Deluge, well, I deleted it, I probably don't want it back

No idea about the architecture here but it would probably be as simple as a flag that gets set once a torrent begins seeding?

Change History (1)

comment:1 Changed 4 years ago by Cas

  • Resolution set to Duplicate
  • Status changed from new to closed

Duplicate of #1032

Note: See TracTickets for help on using tickets.