Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#283 closed bug (Fixed)

resuming a paused seeding torrent fails

Reported by: danii Owned by: andar
Priority: major Milestone:
Component: Core Version: 0.6.0svn
Keywords: resume seeding Cc:

Description

Deluge 0.6.0.0r3225

resuming a paused seeding torrent fails, pausing a single seeding torrent just gives out:

[DEBUG   ] toolbar:151 on_toolbutton_resume_clicked
[DEBUG   ] menubar:222 on_menuitem_resume_activate
[DEBUG   ] core:395 Resuming: ['dcab4cf8c0a58754a2c8ebf81d1de3be31b4e06b']
[DEBUG   ] core:607 torrent_resumed signal emitted
[DEBUG   ] signals:97 torrent_resumed signal received..

no error but with resume all:

systemtray:276 on_menuitem_resume_all_activate
[WARNING ] torrentmanager:436 Unable to resume torrent 5c236425e2e61d22a8dabd4657ecfa36a0775704
[WARNING ] torrentmanager:436 Unable to resume torrent 409b686058f03fb03779a440e31bbf5732250680
[WARNING ] torrentmanager:436 Unable to resume torrent d4e0c3f10ee07b78f4c66c6b34066a4305daabce
[WARNING ] torrentmanager:436 Unable to resume torrent a2180cd9c41e439c23fb891ef2c6779ec3c0c2b8
[WARNING ] torrentmanager:436 Unable to resume torrent 62c6b0b1c2531f68acae6921f09883d101d25055
[DEBUG   ] core:617 torrent_all_resumed signal emitted
[DEBUG   ] signals:107 torrent_all_resumed signal received..

the 3rd torrent is the one paused, 4th is queued for downloading, 2nd is seeding and the remaining 2 are downloading

also when you add a torrent that was already completed for seeding, if during the check it gets in the download queue, when the check completes torrent resumes seeding as expected, but if the queue is empty or not full, while checking the torrent is in paused state and when the check completes the torrent remains paused, it's probably related with the above problem of resuming seeding torrents

Change History (10)

comment:1 Changed 13 years ago by andar

I have committed [3227] as a possible fix. Please test it and let me know if the problem is resolved.

comment:2 Changed 13 years ago by danii

updated to [3227] done some preliminary testing nothing changed besides the logs

resume individual torrent:

[DEBUG   ] menubar:222 on_menuitem_resume_activate
[DEBUG   ] core:395 Resuming: ['dcab4cf8c0a58754a2c8ebf81d1de3be31b4e06b']
[DEBUG   ] torrent:213 set_state_based_on_ltstate: 6
[DEBUG   ] core:607 torrent_resumed signal emitted
[DEBUG   ] signals:97 torrent_resumed signal received..

Resume All:

[DEBUG   ] systemtray:276 on_menuitem_resume_all_activate
[DEBUG   ] torrent:213 set_state_based_on_ltstate: 2
[WARNING ] torrentmanager:436 Unable to resume torrent 5c236425e2e61d22a8dabd4657ecfa36a0775704
[DEBUG   ] torrent:213 set_state_based_on_ltstate: 6
[WARNING ] torrentmanager:436 Unable to resume torrent 409b686058f03fb03779a440e31bbf5732250680
[DEBUG   ] torrent:213 set_state_based_on_ltstate: 2
[WARNING ] torrentmanager:436 Unable to resume torrent d4e0c3f10ee07b78f4c66c6b34066a4305daabce
[DEBUG   ] torrent:213 set_state_based_on_ltstate: 6
[DEBUG   ] torrent:213 set_state_based_on_ltstate: 2
[WARNING ] torrentmanager:436 Unable to resume torrent a2180cd9c41e439c23fb891ef2c6779ec3c0c2b8
[DEBUG   ] torrent:213 set_state_based_on_ltstate: 2
[WARNING ] torrentmanager:436 Unable to resume torrent 62c6b0b1c2531f68acae6921f09883d101d25055
[DEBUG   ] core:617 torrent_all_resumed signal emitted
[DEBUG   ] signals:107 torrent_all_resumed signal received..

I've kept my config so all torrents are the same as before, please tell me if you need me to test with a clean config

comment:3 Changed 13 years ago by andar

This seems right to me. You are trying to resume torrents that are not in a paused state. Are they queued? Do you have your max active seeds set to a reasonable limit? Try setting it to -1 to make sure all seeds get started.

comment:4 Changed 13 years ago by andar

I've made some more changes to the pause/resume code in [3228] to try to resolve this issue. Please give it a try.

comment:5 Changed 13 years ago by danii

ops I missed something, the paused torrent doesn't appear in the Resume All log, so you are right those 5 aren't in paused state, but resuming the paused seeding torrent fails silently, I'm going to try the new code

comment:6 Changed 13 years ago by danii

at [3228] still nothing, because of the update, had to recheck all torrents, so I found out if I force a recheck and resume, while the torrent is in queue for recheck or rechecking, resume works, and when the check completes the torrent goes from paused to seeding, now the resume all only complaints of not being able to resume the queued for download torrent, I'm going to try a clean config

comment:7 Changed 13 years ago by danii

  • Resolution set to fixed
  • Status changed from new to closed

clean config and [3228] solved the problem

comment:8 Changed 13 years ago by danii

I was configuring deluge again and I found the real problem, I had "Stop seeding when share ratio reaches" enabled before, so when I turned it on again the problem was back, at least I could pinpoint the problem, at least I hope so

comment:9 Changed 13 years ago by andar

Aha! There was definitely a bug there and it has been fixed in [3230]. I think we can finally lay this ticket to rest.

comment:10 Changed 13 years ago by anonymous

  • Milestone 0.6.0 deleted

Milestone 0.6.0 deleted

Note: See TracTickets for help on using tickets.