Opened 9 years ago

Closed 2 years ago

#491 closed bug (Duplicate)

Rechecking indefinitely when external disk is not available

Reported by: VincentBeers@… Owned by: andar
Priority: minor Milestone: 2.0
Component: Core Version: 1.2.3
Keywords: external disk, checking Cc: cgreco

Description

I have two external hard disks of which I sometimes only have one connected to my PC. However, if I do this, the torrents that belong to the other disk stay on "Checking... 0.00%" indefinitely and Deluge will never get to the point where it starts (re)checking the files on my other external hard disk. It doesn't even "error" these torrents, it plain keeps them in paused "checking" mode until I connect the drive and restart Deluge!

Using XUbuntu 8.04, disks are mounted to /media/disk/ and /media/IOMEGA HDD/.

Change History (9)

comment:1 follow-up: Changed 9 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

comment:2 in reply to: ↑ 1 Changed 9 years ago by genesys87

  • Keywords external disk checking added
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 0.9.09 (1.0.0_RC9) to 1.1.7

Replying to andar: Absolutely it's not fixed: I'm using 1.1.7, and I have the same problem; when I open deluge, but the external disk it's not plugged in, deluge stay fixed in checking the torrents on the external disk; when I plug in the disk, the torrents begin recheking, even if they are completed!!!

comment:3 follow-up: Changed 8 years ago by damoxc

Is this still occurring with the latest libtorrent and deluge?

comment:4 in reply to: ↑ 3 Changed 8 years ago by DaVince

  • Version changed from 1.1.7 to 1.2.0_rc4

Replying to damoxc:

Is this still occurring with the latest libtorrent and deluge?

Just checked; it does with 1.2.0rc4. Reproduction instructions are as follows:

  • Load a torrent and set its storage to a mounted external disk.
  • Close Deluge.
  • Unmount or even unplug the disk.
  • Start Deluge.

Instead of showing any kind of "source not found" error, Deluge just sets all torrents for that disk to "Checking: 0.00%" and Deluge has to be restarted before the remounted disk is recognized.

comment:5 Changed 8 years ago by Cas

  • Component changed from other to core
  • Milestone set to 1.4.0
  • Version changed from 1.2.0_rc4 to 1.2.3

I have checked that this still occurs with 1.2.3, lt 0.14.10 and 0.15.

If the disk is missing deluge puts all torrents to checking along with losing all the progress of any paused torrents. this results in all files needing to be rechecked however deluge does not require a restart to recognise the disk if it is remounted.

comment:6 Changed 7 years ago by Cas

  • Priority changed from major to minor

A combination of these two features should fix this issue.

Error-out if downloaded torrent data is suddenly missing #1032 Skip Hash Check - Seed Mode #1294

comment:7 Changed 7 years ago by cgreco

  • Cc cgreco added

Hi,

I'm forwarding this bug report from Debian since it seems to be pretty similar. http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=613443

--

From: George Shuklin <amarao at desunote dot ru> Subject: deluge: Stalled state with endless 'checking' state if save-to folder does not exist

If deluge terminated by some event (f.e. reboot) after start it checking file consistency. But if folder for saved torrents does not exists it keep 'checking' state endlessly.

How to reproduce:

1) Set 'save to' value to some path. 2) Start downloading torrent with folders within torrent 3) Kill deluge by -9 signal 4) remove 'save to' folder (and, probaly) upper directory [not sure] 5) Start deluge

Expected behavior:

some kind of error mark for 'bad' torrents.

Actual: Got endless 'checking' state without progress bar and 30-40% CPU load

P.S. I got this state after mount failure for deluge volume, when my /srv/ catalogue was empty instead /srv/deluge/temp-download.

comment:8 Changed 3 years ago by Cas

  • Milestone changed from 1.4.0 to 2.0.0

comment:9 Changed 2 years ago by Cas

  • Resolution set to Duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.