Opened 6 years ago

Closed 6 years ago

#1956 closed bug (Fixed)

[Win32] Errors: "The parameter is incorrect" and "Reached the end of file"

Reported by: xzilvinas Owned by:
Priority: critical Milestone: 1.3.4
Component: libtorrent Version: 1.3.3
Keywords: Cc:

Description

Its bug when your torrent haves big sized files ~4gb. not the size of all files in torrent, but if there is big files like .mkv or .iso in there about ~4gb size the error comes up and download stops, its happens with about 90% of torrents like that.

Change History (13)

comment:1 in reply to: ↑ description ; follow-up: Changed 6 years ago by cinderblock

Replying to xzilvinas:

Its bug when your torrent haves big sized files ~4gb. not the size of all files in torrent, but if there is big files like .mkv or .iso in there about ~4gb size the error comes up and download stops, its happens with about 90% of torrents like that.

I download large files all the time and have had no issues. I'm not running windows which I doubt is the main cause of the problem. I'd bet it's because you're running fat32 which has a filesize limit at ~4GB. Can you confirm?

comment:2 Changed 6 years ago by cinderblock

I think thePACE just reported to the deluge google group that large files work fine for him. I assume he's using NTFS which does support large files.

comment:3 in reply to: ↑ 1 Changed 6 years ago by xzilvinas

Replying to cinderblock:

Replying to xzilvinas:

Its bug when your torrent haves big sized files ~4gb. not the size of all files in torrent, but if there is big files like .mkv or .iso in there about ~4gb size the error comes up and download stops, its happens with about 90% of torrents like that.

I download large files all the time and have had no issues. I'm not running windows which I doubt is the main cause of the problem. I'd bet it's because you're running fat32 which has a filesize limit at ~4GB. Can you confirm?

Mine all hdd is formated to NTFS, in deluge 1.3.1 there is no such problem, but in this 1.3.3 there is, if there is single files in folder that is big. Not with all of them, but 90% of them and error stops it. Then I just use another torrent client for those torrents.

comment:4 Changed 6 years ago by Cas

Since there already known issues with the libtorrent supplied with 1.3.3 for Windows it is not unsurprising there may be an issue like this. Hopefully a release including libtorrent 0.15.8 should be soon.

comment:5 Changed 6 years ago by Cas

  • Component changed from windows to libtorrent
  • Priority changed from blocker to critical
  • Summary changed from Bug in 1.3.3 always error when downloading big files to [Win32] Error when downloading big files

As I said in the other ticket you opened you need to tell us what the error message is that you are seeing. Also you have not included what version of Windows you are using.

You can test the latest version of libtorrent 0.15.8 as I have outlined in this forum thread. http://forum.deluge-torrent.org/viewtopic.php?f=12&t=37601#p160049

However there is still outstanding issues even with libtorrent 0.15.8 so you may wish to install Deluge 1.3.1 instead.

comment:6 follow-up: Changed 6 years ago by xzilvinas

I use Win7 x64. The error is always the same "The parameter is incorrect: and the address to the file i download" pvz: The parameter is incorrect: Y:/Downloads/movie.mkv.

I hope i helped.

comment:7 in reply to: ↑ 6 Changed 6 years ago by xzilvinas

Replying to xzilvinas:

I use Win7 x64. The error is always the same "The parameter is incorrect: and the address to the file i download" pvz: The parameter is incorrect: Y:/Downloads/movie.mkv.

I hope i helped.

add: tested libtorrent 0.15.8, the problem is still there, no change, the same error.

comment:8 Changed 6 years ago by Cas

  • Summary changed from [Win32] Error when downloading big files to [Win32] Errors: "The parameter is incorrect" and "Reached the end of file"

"The parameter is incorrect"

This is the outstanding bug that remains in 0.15.8, there is more detail on this bug at the links below. In the meantime I suggest you install Deluge 1.3.1

https://bugs.launchpad.net/qbittorrent/+bug/871328

http://code.google.com/p/libtorrent/issues/detail?id=251

comment:9 follow-up: Changed 6 years ago by xzilvinas

Just tested whit new lib 0.15.9, and the problem remains.

comment:10 in reply to: ↑ 9 Changed 6 years ago by Cas

Replying to xzilvinas:

Just tested whit new lib 0.15.9, and the problem remains.

What version of Deluge are you using? When you say the problem remains which one specifically?

comment:11 follow-up: Changed 6 years ago by xzilvinas

deluge 1.3.3 when the file is 2gb+ the error "The parameter is incorrect:" and ~10hours ago just showed up new version of lib 0.15.9, so i tested it with it, but the error still shows for bigger files then 2gb.

comment:12 in reply to: ↑ 11 Changed 6 years ago by Cas

  • Milestone changed from 1.3.4 to 1.3.x

Replying to xzilvinas:

deluge 1.3.3 when the file is 2gb+ the error "The parameter is incorrect:" and ~10hours ago just showed up new version of lib 0.15.9, so I tested it with it, but the error still shows for bigger files then 2gb.

Ok I have also just replicated the error with 0.15.9 and 3GB file so I will inform Arvid about the issue.

Before I was mainly testing with trunk build which strangely seems to not be affected.

comment:13 Changed 6 years ago by Cas

  • Milestone changed from 1.3.x to 1.3.4
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in libtorrent 0.15.10

Note: See TracTickets for help on using tickets.