Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#2482 closed bug (Invalid)

Global options not working as expected

Reported by: Sepero Owned by:
Priority: minor Milestone:
Component: Unknown Version: 1.3.6
Keywords: configuration Cc:

Description

While making custom edits to the code, I have found that first_last prioritization is sometimes not internally being set as True when it should be.

first_last priority is only being set to torrents if they are added while the option is already on. A torrent that is added before the option is turned on will not be able to be changed unless it is removed and re-added.

The expected behavior would be that global options are globally True or globally False, and not changing on a per torrent basis.

Change History (3)

comment:1 Changed 7 years ago by bro

  • Resolution set to Invalid
  • Status changed from new to closed

The options in preferences->downloads only apply to torrents added after the options are set. This is not a bug, but how it's supposed to work. To change the settings for an already added torrent, you need to use the Options tab in the lower menu below the torrent list.

As I understand what you write, it works as I describe, so closing.

comment:2 Changed 7 years ago by Sepero

My apologies. I'm a new user of Deluge and I wasn't aware of that Options area. Thank you for clarifying, bro.

comment:3 Changed 6 years ago by Cas

  • Milestone 1.3.x deleted

Milestone deleted

Note: See TracTickets for help on using tickets.