Opened 13 years ago

Closed 10 years ago

#693 closed bug (Fixed)

share ratio limit not respected

Reported by: wallfur@… Owned by: andar
Priority: major Milestone: 1.3
Component: Core Version: 1.3.1
Keywords: ratio limit upload Cc: boteeka

Description

running on 64 bit ubuntu.

i recently had my 'net connection "shaped" (which caused havoc for my household and our voip phone) because deluge does not respect my share ratio settings.

i already have it set to share more than i receive, disabled time limits (i think?) by setting both time ratio and time to -1, and also set it to stop seeding when the ratio is reached. doing some manual calculations on that current torrent, it is clear deluge has gone way over the share ratio i set, and is still uploading as much as it can, even after setting the upload speed limit for it to 0 or a low value. i think the cause might be that i have not finished downloading yet.

i don't know how you determine when to stop uploading programatically but i have a couple of logic suggestions:

take the greater of 2 measurements of download size - the total of the blocks needed to download selected file(s) in a torrent and the total file bytes actually downloaded. if you're only downloading 2 files out of a torrent with 10 files the ratio should not be based on the size of the full 10 files, this measurement needs to be dynamic to accommodate people adding/removing file selections from a torrent. also measuring the actual file bytes received will prevent people from manipulating upload ratios by "choosing not to download files" after they have already got them.

multiply the download total by the share ratio then just stop uploading altogether when that limit is reached, with 2 exceptions: don't stop in middle of a block's transfer; and, if the user has set their share ratio to < 1 and is sill downloading, allow uploading until ratio has reached 1 to help prevent them leeching.

Change History (9)

comment:1 Changed 13 years ago by wallfur@…

correction: i managed to slow the uploads by setting the max up speed to 0.1KB/s, it just took a while for the displayed rate to drop.

comment:2 Changed 13 years ago by andar

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 12 years ago by wallfur@…

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 1.0.5 to 1.1.5

not fixed? it happened again. ratio was 5.261, this time in version 1.1.5 what can i send to help debug?

comment:4 Changed 12 years ago by andar

  • Resolution set to fixed
  • Status changed from reopened to closed

This should be fixed in the latest version.

comment:5 Changed 12 years ago by boteeka

  • Cc boteeka added
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 1.1.5 to 1.2.0

Still does not seem to be fixed in 1.2. As a matter of fact it only happened to me with 1.2 and never before. But now not a single torrent gets stopped seeding automatically.

Running on Ubuntu 9.10 64 bit.

comment:6 Changed 11 years ago by Cas

  • Milestone set to 1.3.0
  • Priority changed from major to minor
  • Status changed from reopened to pending

can you please recheck with latest 1.2.2, i have a similar setup and have not seen this.

comment:7 Changed 11 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:8 Changed 10 years ago by Routh

  • Priority changed from minor to major
  • Status changed from closed to reopened
  • Version changed from 1.2.0 to 1.3.1

I am reopening this as a major bug. I am currently looking at removing deluge altogether because of it. I have my share ratio limit set to 1 and yet I currently have two torrents at a share ratio of 3.33 and 4.78 on version 1.3.1 (headless) on Ubuntu 11.04 Server. This is wreaking havoc with my ISP.

comment:9 Changed 10 years ago by Cas

  • Resolution set to fixed
  • Status changed from reopened to closed

we have applied new fixes for next release.

Note: See TracTickets for help on using tickets.